Two Versions of a Labview Add-On or Module on the Same Computer

Updated Dec 18, 2019

Reported In

Software

  • LabVIEW
  • Vision Development Module

Issue Details

I know that you can have two versions of LabVIEW installed on your computer. However, when I try to install two versions of an add-on, such as the Vision Acquisition Software or the Report Generation Toolkit, only one is possible. If I install a newer version, it overwrites the older one. If I try to install an older one, I get the following message: 
This feature will not be installed. 

A higher version of this product is already installed on your computer. 

Additionally, I wanted to know if it is possible to install two versions of a LabVIEW module such as the Vision Development Module to utilize with two different versions of LabVIEW, or if I will get the same error as above. 

Solution

Although two versions of LabVIEW can coexist on the same machine, there can only be one version of add-on such as additional toolkits installed on the same machine. 

Different versions of LabVIEW Modules, such as the Real-Time Module or the Vision Development Module, can be installed on the same machine. In addition, with the installation through NI Package Manager, there is an option to install support for the compatible versions of LabVIEW that are included with the installation. For instance, if I wanted to include Vision Support for LabVIEW 2016, I would need to select the option for that within the installation panel. 
 

Additional Information

A possible workaround is to use a virtual machine which has one of the versions of LabVIEW and the add-on. 

Additionally, some add-ons are compatible with multiple versions of LabVIEW. Check the readme file for the add-on for more information.
 

WAS THIS ARTICLE HELPFUL?

Not Helpful