TestStand Version Selectorを使用しで複数のTestStandバージョンを管理する

更新しました Apr 15, 2019

使用製品

Software

  • TestStand

問題

  • あるバージョンのTestStandがインストールされていますが、他のバージョンもインストールしたいと思います。私は以下のこと確認したいと思います。
    • 複数のバージョンのTestStandを同時にインストールすることはできますか?
    • インストールされている複数のバージョンを切り替えるにはどうすればいいですか?

     
  • TestStandの複数のバージョンがインストールされています。 TestStand Sequence Editorを起動しようとすると、何も起こらないか、次のエラーが表示されます
 
The TestStand Engine cannot be initialized. You are trying to run the [x.y.z] sequence editor with the [x.y.z] engine. This is not supported. You can use the TestStand Version Selector to change the active TestStand engine version if you have more than one version of TestStand installed.
 
 

解決策

一般に、複数のバージョンのTestStandを並行してインストールすることが可能です。ただし、いつでもアクティブにして実行できるのは1つのバージョンのTestStandのみです。

TestStand Version Selectorツールで実行したいバージョンを選択することができます。
 


メモ: 同じバージョンの32ビット版と64ビット版のTestStandがインストールされている場合は、それらが同じバージョンであることを確認してください(32-bit 2017と64-bit 2017、または32-bit 2017 SP1と64-bit 2017 SP1)。たとえば、TestStand 2017 32-bitとTestStand 2017 SP1 64-bitを混在させることはできません。


以下の方法でTestStand Version Selectorを起動できます。
  • Windows 10及び 7:スタートメニューを使用して、スタート>>すべてのプログラム>>National Instruments>>TestStand>>TestStand Version Selector を選択します。
  • Windows 8および8.1:スタート画面でNIランチャーをクリックして、TestStand>>TestStand Version Selector を選択します。
  • C:\Program Files<x86>\National Instruments\Shared\TestStand Version Selector\TSVerSelect.exeを実行します。


上記の問題セクションに表示されているエラーメッセージは、TestStand Version Selectorを開いて目的のバージョンをアクティブにすることで解決できます。エラーメッセージは、現在アクティブなバージョンではないバージョンのTestStandを開こうとしたからです。エラーメッセージは、どのバージョンが現在アクティブで、どのバージョンを開こうとしているかを示します。上記のケースでは、Teststand 4.2.1がアクティブとして設定されていますが、TestStand 17.0.0を開こうとしています。

追加情報

  • 特定のTestStandバージョンがアクティブになったときに何が起こるかについての詳細は、TestStand Version Selectorを参照してください。

  • TestStand 3.1のリリースに伴い、TestStand Version Selectorが導入され、複数のバージョンのTestStandをコンピュータにインストールできるようになりました。詳細については、TestStand 3.1リリースノートを参照してください。

 

この記事はお役に立ちましたか?

いいえ