Software Required for SoftMotion Hardware

Updated Nov 9, 2018

Reported In

Hardware

  • NI-951X
  • NI-950X

Software

  • LabVIEW SoftMotion Module

Issue Details

What interface modes and software packages are required or recommended for my motion hardware?

Solution

Below is a chart that specifies the required, recommended, optional, and incompatible interface modes and software packages for motion interfaces operating with National Instruments hardware:
 

Additional Information

Note 1: The NI 951x Drive Interface Modules no longer support LabVIEW FPGA mode as of CompactRIO Device Drivers 17.6 and LabVIEW 2017 SP1. Use a previous version of CompactRIO Device Drivers to continue using these modules in LabVIEW FPGA mode. 

Note 2: It is possible, though highly discouraged, to access a 950x module without the Real-Time Module using a 914x Ethernet Expansion Chassis.

WAS THIS ARTICLE HELPFUL?

Not Helpful