NI Package Manager Is Not Up-To-Date

Updated Nov 20, 2018

Reported In

Software

  • Package Manager

Issue Details

When I try to install new software or update my installation of NI Package Manager, I see errors that state:

"There was a problem executing your request. Package requires a newer version of Package Manager."


Alternatively, when I select the UPDATES tab, I see the following error:

"Your system needs the latest version of the upgrader in order to upgrade Package Manager. Restart Package Manager or manually update the Package Manager Upgrader package."

 

Solution

This error can appear when the version of NI Package Manager installed on the host computer is older than the latest version released for the current product being installed. To fix this:

1. Restart NI Package Manager. If this doesn't trigger an automatic update, move to the next step.
2. Manually update NI Package manager. 
          a. NIPM needs infrastructure packages to update itself, which can be added by clicking on the gear icon in the top right, and then checking the boxes to mirror the picture below:
       
         b. Go back to the upgrades tab. The "upgrader" will be listed there to upgrade to the correct NI Package Manager version.
 

WAS THIS ARTICLE HELPFUL?

Not Helpful