Error Deploying Axis: Module Components Are Missing, Incompatible, or Not Properly Started

Updated May 3, 2018

Reported In

Hardware

  • AKD-P02406-NBEC-0000
  • AKD-P00307-NBEC-0000

Software

  • LabVIEW SoftMotion Module

Driver

  • NI-Industrial Communications for EtherCAT

Issue Details

I have an AKD EtherCAT drive, and whenever LabVIEW tries to deploy the AKD axis, the deployment completes with errors as seen in the image below:
What is causing the error and what can I do deploy the AKD axis without this error?

 

Solution

The AKD axis deployment error is due to an incompatibility between your specific versions of the NI SoftMotion Module and the Industrial Communications for EtherCAT driver.

Reference the LabVIEW NI SoftMotion Readme Files to make sure that your version of NI SoftMotion and the Industrial Communications for EtherCAT driver are compatible.

Additional Information

If you need to downgrade the Industrial Communications for EtherCAT driver, uninstall the more recent version first before installing the appropriate version of the driver. You can follow the KnowledgeBase article, How Do I Uninstall or Repair National Instruments Software, to properly uninstall the driver.

The Industrial Communications for EtherCAT drivers can then be found through ni.com/drivers.

WAS THIS ARTICLE HELPFUL?

Not Helpful