报错:缺少DAQmx.rc

更新 Mar 10, 2020

适用于

软件

  • LabVIEW

司机

  • NI-DAQmx

问题详述

  • 我在运行VI时收到警告,说尝试运行使用NI-DAQmx选板的VI时缺少DAQmx.rc
-未找到该VI需要的驱动程序或工具包组件。缺少资源文件“ daqmx.rc”。
  • 我的所有NI-DAQmx VI在当前使用版本的LabVIEW中均显示为问号。但它们在较老版本的LabVIEW中能够正常运行。

解决方案

造成此错误的原因是:未安装完整的NI-DAQmx驱动程序、安装的版本与您的LabVIEW版本不兼容,或者在安装驱动程序期间数据损坏。

要解决此问题,请下载与您的LabVIEW版本兼容NI-DAQmx驱动程序,然后运行安装向导。完成以上操作之后,请重新启动计算机。现在,您在NI Measurement&Automation Explorer(NI MAX)中的“软件”菜单将看到已安装的“ NI-DAQmx设备驱动程序”:

如果NI-DAQmx驱动程序的版本与您的LabVIEW版本兼容,并且错误仍然存在,请卸载DAQmx驱动程序并重新安装

相关信息

  • 如果仅安装DAQmx运行引擎 (Runtime Engine),这个问题便很常见。运行引擎 (Runtime Engine) 是一个独立的实用程序,可让您运行使用NI-DAQmx制作成的应用程序,但其本身无法用于程序开发。在这种情况下,您可以在NI MAX中“ 我的系统 ”菜单下的“ 软件 ”菜单找到运行引擎。
  • daqmx.rc文件应位于以下路径中。如您打开该文件夹,但未找到文件,请重新安装NI-DAQmx驱动程序。
C:\ Program Files(x86)\ National Instruments \ LabVIEW (当前使用版本) \ resource \ objmgr
  • 查看NI-DAQmx下载页面上相关驱动程序版本的自述文件,即可查看NI-DAQmx的所有兼容性要求(硬件,软件,操作系统等)。