Missing DAQmx.rc Error

Updated Jun 7, 2019

Reported In

Software

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

Driver

  • NI-DAQmx

Issue Details

  • I get an error saying that DAQmx.rc is missing when trying to run a VI that uses the DAQmx palette.
  • All my DAQmx VIs are shown as question marks in LabVIEW. They act normally in older versions of LabVIEW.

Solution

This error is caused because the full NI-DAQmx driver is not installed or the version installed is not compatible with your version of LabVIEW.

To fix this, download a version of the NI-DAQmx driver compatible with your version of LabVIEW and run the installation wizard. After doing so, be sure to restart your computer. Now, your "Software" menu in NI MAX will show the "NI-DAQmx Device Driver" as being installed:

Additional Information

  • This is a common issue encountered when only the DAQmx Runtime Engine is installed. The Runtime Engine is a separate utility that will allow you to run applications made with DAQmx, but not develop anything with it. If this is the case, the Runtime Engine will show up in NI MAX in the "Software" menu under the "My System" menu.
  • You can see all the compatibility requirements (hardware, software, operating system, etc.) for NI-DAQmx by reviewing the readme of the relevant driver version located at the NI-DAQmx download page .

WAS THIS ARTICLE HELPFUL?

Not Helpful