Windows Vista、7、8、10对传统的NI-DAQ(Legacy)的支持

更新 Jan 30, 2019

适用于

Hardware

  • Multifunction I/O Device

Driver

  • Traditional NI-DAQ

Operating System

  • Windows

问题详述

我想在Windows Vista,Windows 7,Windows 8或Windows 10上安装Traditional NI-DAQ(Legacy)驱动。
  • 这些64位(x64)的Windows版本是否支持传统的NI-DAQ(Legacy)?
  • 为什么我的LabVIEW VI、可执行文件或应用程序在这些Windows版本上无法运行或是显示已损坏?
  • 在这些Windows版本上安装Traditional NI-DAQ(Legacy)时,为什么会遇到问题或报错?
  • 为什么我的DAQ设备和模块没有出现在这些版本的Windows的设备管理器中或是Measurement&Automation Explorer(MAX)中?

解决方案

传统NI-DAQ(Legacy)与NI-DAQmx

目前,NI向有需要在Windows Vista、7、8等操作系统的32位版本x86下运行的legacy代码的开发者提供Traditional NI-DAQ (Legacy) beta驱动,以作为暂时支持。在2003年,NI-DAQmx取代了传统的NI-DAQ(Legacy)。 NI强烈建议您使用NI-DAQmx驱动用于您的项目,并建议将现有的传统NI-DAQ(Legacy)应用程序迁移到NI-DAQmx。有关程序迁移的更多信息,请查看NI-DAQmx入门指南

传统的NI-DAQ(Legacy)Windows 64位支持

传统的 NI-DAQ(Legacy) 不支持64位版本的Windows。这些版本的Windows仅支持较新的NI-DAQmx驱动。

传统的NI-DAQ(Legacy)Windows 32位支持

使用本文确定系统上安装的Traditional NI-DAQ的版本
传统的NI-DAQ(Legacy)的Windows版本支持
传统的NI-DAQ(Legacy)版本Windows VistaWindows 7的Windows 8Windows 10
<7.4.4不支持不支持不支持不支持
7.4.4非官方*不支持不支持不支持
7.5支持的支持的支持的非官方*
注意:注意到的所有Windows版本仅为32位系统。
*此安装可能有效,但NI不支持。

传统NI-DAQ(Legacy)安装疑难解答

本文是否有帮助?

无帮助