Error When Downgrading Real-Time PXI Controller Software

Updated May 3, 2018

Reported In

Hardware

  • PXIe-8840
  • PXIe-8820

Software

  • LabVIEW 2014 SP1 Full
  • LabVIEW 2015 Full
  • LabVIEW 2014 Full
  • LabVIEW 2014 Professional
  • LabVIEW 2014 SP1 Professional
  • LabVIEW 2015 Professional

Issue Details

I have a PXI Real-Time Controller that I'd like to downgrade the software on from 2014 SP1 or higher to 2014. I also have LabVIEW 2014 SP1 and 2015 installed on my normal host machine, and I'm using that computer to downgrade the software. I'm working with a customer who needs to use older software, or my application requires me to go back a version in software. When I try to downgrade to 2014, I receive the following error:

Cannot continue because of the following unresolved dependencies : 
NI RT Extensions for SMP (MultiCore Support) 14.0.0 requires Base System 11.0


How do I resolve this error?

Solution

There are a few options to work around this error.
  • Try installing software on the chassis from a different computer. 
  • Uninstall only NI RT Extensions for SMP (MultiCore Support) 14.5.0 version, then downgrade the remaining software on the target to 14.0. 
    • Then, install only NI RT Extensions for SMP (MultiCore Support) 14.0.0 on the target.
  • Downgrade all of the components, except for NI RT Extensions for SMP (MultiCore Support). Then downgrade just the NI RT Extensions for SMP (MultiCore Support).

WAS THIS ARTICLE HELPFUL?

Not Helpful