Windows 10でNIソフトウェアのインストール時にMicrosoft .NET 2.0エラーが発生する

更新しました Nov 27, 2019

使用製品

Software

  • TestStand
  • LabVIEW
  • LabWindows/CVI

Operating System

  • Windows

問題

Windows 10コンピュータでNIソフトウェアをインストールしようとすると、Microsoft .NET Framework 2.0エラーが発生します。

解決策

この問題を解決するには、Microsoft .NET 3.5 Frameworkをダウンロードして、インストールが完了したら、WindowsコントロールパネルでMicrosoft .NET 3.5 Frameworkを有効にする必要があります。ダウンロードと詳細については、関連リンクを参照してください。

追加情報

多くのNIソフトウェアプログラムは、Windows Vista(2007)からWindows 7(2011)までの間、Windowsオペレーティングシステムで使用されるMicrosoft .NET Framework 2.0で開発されました。Windows 8は、Microsoft .NET Framework 4.5と共にリリースされ、Windows 10はMicrosoft .NET Framework 2.0との下位互換性がないMicrosoft Framework 4.6と共にリリースされました。
 

そのため、Microsoft .NET Framework 2.0で開発されたソフトウェアを実行するには、.NET Framework 2.0、または少なくとも下位互換性のある.NET Frameworkをインストールする必要があります。この場合、Microsoft .NET Framework 3.5はMicrosoft .NET Framework 2.0と下位互換性があります。
 

そこから、デフォルトでWindows 10と互換性のないMicrosoft .NET Framework 3.5を有効にする必要があります。詳細は、関連リンクを参照してください。

この記事はお役に立ちましたか?

いいえ