NI Software - Microsoft .NET 2.0 Error in Windows 10

Updated May 3, 2018

Reported In

Software

  • TestStand
  • LabVIEW
  • LabWindows/CVI

Operating System

  • Windows

Issue Details

When I run NI Software on a Windows 10 computer I get a Microsoft .NET Framework 2.0 error

Solution

Download the Microsoft .NET 3.5 Framework (see in related links below) and after installation has completed enable the Microsoft .NET 3.5 Framework within your Windows Control Panel (reference Microsoft KB "Install the .NET Framework 3.5 on Windows 10" in the related links below.) 

Additional Information

Many NI software programs were developed on the Microsoft .NET 2.0 Framework which was used on Windows operating systems starting with Windows Vista (2007) and running through Windows 7 (2011). Windows 8 was released with the Microsoft .NET 4.5 Framework and Windows 10 was released with the Microsoft 4.6 Framework which is not backwards compatible with the Microsoft .NET 2.0 Framework. 

So to run software that was developed on the Microsoft .NET 2.0 Framework we need to install the .NET 2.0 Framework or at least a .NET Framework that is backwards compatible with it. In this case the Microsoft .NET 3.5 Framework is backwards compatible with the Microsoft .NET 2.0 Framework.

From there we are able to install the Microsoft .NET 3.5 Framework which is not compatible with Windows 10 by default but can be enabled per the steps within the Microsoft KB "Install the .NET Framework 3.5 on Windows 10". 

WAS THIS ARTICLE HELPFUL?

Not Helpful