XNET互換性レイヤーでサポートされていないモジュール

更新しました Feb 12, 2021

使用製品

ハードウェア

  • NI-9860
  • PCIe-8510
  • PXIe-8510

ドライバ

  • NI-CAN
  • NI-XNET 16.1

問題

  • XNET互換性レイヤー(XCL)を利用して、古いNI-CANコードをXNETデバイスに移行しようとしています。 XCLをサポートしていないデバイスはありますか?
  • いくつかのXNETカードとXNET互換性レイヤ(XCL)を利用したPXIeシステムがあります。最近、PXIe-8510をアプリケーションに追加しましたが、MAXエラーが発生し、XCLをXNETデバイスで使用できなくなりました。

解決策

XNET互換性レイヤ(XCL)は、NI-XNET17.0.1より前のトランシーバケーブルを使用するカードではサポートされていません。これには、PXIe-8510、PCIe-8510、およびNI 9860デバイスが含まれます。

これらのハードウェアをXCLを利用するアプリケーションに追加すると、NI-XNET 16.1以前のバージョンがインストールされている場合、MAXエラーやクラッシュ動作など、Measurement&AutomationExplorerで予期しない動作が発生します。