Can't See the Network Settings Tab in NI MAX

Updated May 17, 2018

Reported In

Software

  • Measurement & Automation Explorer (MAX)
  • LabVIEW Real-Time Module

Driver

  • NI-RIO

Issue Details

  • I am getting an error in NI MAX saying the my IP settings are inconsistent, when I go to select the Network Setting Tab I cannot modify/change the settings. When I reset the cRIO to safe mode I am not getting any options that allow me to change the IP address to static. 
  • When I go to the Network Setting tab in NI MAX it perpetually searches for adapters 

Solution

This issue could be caused by multiple reasons, attempt the following troubleshooting steps to try and resolve the issue: 
  • Check for any firewalls that may be blocking the device from the system. Also ensure that your firewall is configured to support NI products
  • Check to make sure there are not other devices on your network that has the same IP address. 
    1. Open up a command prompt (Start >> type Run >> type cmd >> <Enter>)
    2. In the command prompt type nslookup <ip address>
    3. Press <Enter>
    4. Check to see if the name of the device associated with the ip address is your expected device.
  • Follow the steps outlined in this document to help remedy inconsistent IP settings on your real-time target
    • If using Windows 10 please check the IPv4 settings by going to Control Panel>>Network and Internet then right click Properties and then navigating to Sharing Panel. Under "Internet Connection Sharing" make sure to check Allow Other Network Users to Connect Through this Computers Internet Connection.  Also list the cRIO as the "Home networking connection"
  • Try doing an IP reset. 
  • Make sure to check your LAN Settings (Control Panel >> Network and Internet >> Internet Options >> Connections >> LAN settings) and uncheck Use Automatic Configuration Script, as seen in the image below: 
 

WAS THIS ARTICLE HELPFUL?

Not Helpful