Will the OPC UA Toolkit run on Phar Lap ETS?

Updated Jul 20, 2018

Reported In

Hardware

  • PXI Controller

Software

  • LabVIEW OPC UA Toolkit
  • LabVIEW Datalogging and Supervisory Control Module

Operating System

  • Windows
  • PharLap
  • NI Linux Real-Time
  • VxWorks

Issue Details

  • Is it possible for my Phar Lap ETS PXI controller to talk directly to my PLC using the LabVIEW 2017 OPC UA Toolkit?
  • Can I install the OPC UA Toolkit to my Real-Time PXI Controller?
  • Why don't I have the option to upgrade the OPC UA Client and Server APIs on my PXI Controller past version 16.0?

Solution

The LabVIEW 2017 OPC UA Toolkit is only compatible with both Windows and NI Linux Real-Time operating systems, so it cannot be installed on a controller running Phar Lap ETS.

Additional Information

OPC UA functionality was taken out of LabVIEW Datalogging and Supervisory Control (DSC) Module after LabVIEW 2016. If you would like to have OPC UA functionality on a controller running Phar Lap ETS, you can install LabVIEW 2016 and the LabVIEW 2016 DSC Module.

WAS THIS ARTICLE HELPFUL?

Not Helpful