エラー7: Report Generation ToolkitのVIを使用したアプリケーションが実行ファイルとして動作しない

更新しました Feb 26, 2019

使用製品

Software

  • LabVIEW
  • LabVIEW Application Builder Module
  • LabVIEW Report Generation Toolkit

問題

Report Generation Toolkit for Microsoft OfficeのVIを使用する実行ファイルを実行すると、次のエラーが発生します。

エラー7: ファイルが見つかりません。ファイルは別の場所にあるか、削除された可能性があります。コマンドプロンプトかファイルエクプローラを使用して、パスが正しいことを確認してください。
 

VIはLabVIEW開発環境で正常に動作し、ビルド処理中にエラーは発生しませんでした。このアプリケーションを動作させるためにビルドに含める必要があるものはありますか?

解決策

これは、レポート生成ツールキットのダイナミックVIがビルド時に含まれていないために発生します。  
 

LabVIEW 2014以降

レポート生成VIを使用してアプリケーションをビルドする場合は、以下の手順を完了する必要があります。

  1. 以下のファイルをLabVIEWプロジェクトに追加します。
    • アプリケーションでMicrosoft Wordを使用している場合は、C:\Program Files(x86)\National Instruments\LabVIEW x.x\vi.lib\Utility\NIReport.llb\Word\NI_Word.lvclass を追加します。
    • アプリケーションでMicrosoft Excelを使用している場合は、C:\Program Files(x86)\National Instruments\LabVIEW x.x\vi.lib\Utility\NIReport.llb\Excel\NI_Excel.lvclass を追加します。
       
  2. アプリケーションプロパティまたは共有ライブラリプロパティダイアログボックスのソースファイルカテゴリから、プロジェクトに追加したクラスファイルに移動して選択します。常に含むリストの横にある右矢印ボタンをクリックして、クラスファイルをアプリケーションに追加します。

メモ: 作成中のアプリケーションにMS Office Report Express VIが含まれている場合は、使用するMicrosoft WordまたはMicrosoft ExcelのテンプレートをLabVIEWプロジェクトとアプリケーションに追加する必要があります。ソースファイルカテゴリで使用するテンプレートを選択し、常に含むリストの横にある右矢印ボタンをクリックして、テンプレートファイルをアプリケーションに追加します。



LabVIEW 8.6 ~ 2013

LabVIEWバージョン8.6から2013では、生成するレポートタイプに応じてVIをダイナミックに呼び出すLabVIEWクラスが使用されています。動的に呼び出すダイナミックVIが使用されている実行ファイルをビルドするには、ビルド仕様でこれらのVIを含める必要があります。

  1. プロジェクトエクスプローラウィンドウで、マイコンピュータを右クリックして追加»フォルダ(スナップショット)を選択します。
  2. C:\Program Files\National Instruments\LabVIEW x.x\vi.lib\Utility\NIReport.llb(ここで、x.xは使用するLabVIEWのバージョンを指します)に移動して、現在のフォルダをクリックします(64ビットOSの場合は、Program Files (x86)の中にあります)。
  3. LVClassフォルダを追加するには、C:\Program Files\National Instruments\LabVIEW x.x\vi.lib\Utility\LVClassまたはC:\Program Files(x86)\National Instruments\LabVIEW x.x\vi.lib\Utility\LVClassに移動して、同様の操作を繰り返して、LVClassフォルダを追加します。
  4. LabVIEWプロジェクトに2つのフォルダができたら、ビルド仕様を右クリックして、新規>>アプリケーション(EXE)からアプリケーションプロパティで下図のようにソースファイルカテゴリの常に含むリストボックスへ追加します。


メモ: 名前の不一致警告を解決するには下記の関連リンクを参照してください。


 

LabVIEW 8.0、8.2、および8.5 

アプリケーションビルダは、プロジェクト内に存在するファイルのみビルド仕様に追加しますので、まずプロジェクトにこれらのファイルを追加する必要があります。


 

これにより、それをアプリケーションビルダ内にダイナミックVIとして追加できます。

MS Office Report Express VIを使用している場合は、アプリケーションに加えてExpress VIで使われているテンプレートを含める必要があります。MS Office Report Express VIの構成は、LabVIEWテンプレートディレクトリにある基本テンプレート、もしくはユーザが作成したカスタムテンプレートのいずれかのレポートテンプレートに依存しています。実行ファイルが「MS Office Report」Express VIとともに使用されている際は、テンプレートもソースファイルタブでサポートファイルとして含める必要があります。実行ファイルがプログラム実行で呼び出すことができるように、「data」ディレクトリへテンプレートを追加します。

 

LabVIEW 7.x

  1. LabVIEW 7.xでWordやExcel dynamic VIを追加するには、アプリケーションビルダのソースファイルタブをクリックして、ダイナミックVIを追加...をクリックします。
    • Microsoft Excelを使用している場合、LabVIEW 7.x\vi.lib\addons\_office\_exclsub.llbのパスを含めます。ファイルダイアログボックスが表示されますので、_Excel Dynamic VIs.viを選択して、OKボタンをクリックします。
    • Microsoft Wordを使用している場合、LabVIEW 7.x\vi.lib\addons\_office\_wordsub.llbのパスを含めます。ファイルダイアログボックスが表示されますので、_Word Dynamic VIs.viを選択して、OKボタンをクリックします。


 

LabVIEW 6.x

LabVIEW Report Generation Toolkit 1.0を使用してアプリケーション(EXE)もしくはDLLをビルドする場合、_wordsub.llbや_exclsub.llbが含まれているサポートファイルディレクトリはアプリケーションもしくはDLLと同じディレクトリであり、Dataというサブディレクトリである必要があります(この場所は、アプリケーションビルダのデフォルトサポートファイルディレクトリです)。エラー7がアプリケーションを実行する際にまだ発生する場合、_wordsub.llbや_exclsub.llbを再リンクするために一括コンパイルする必要があります。一括コンパイルは、ツール>>上級>>一括コンパイル...からおこないます。

追加情報

追加のトラブルシューティング手順は以下のとおりです。
  1. 書き込むパスは、スペースを含むコンピュータ上の正確なパスと一致していることを確認します。
  2. Windowsユーザとアプリケーション(.exe)の両方に読み取り/書き込みのアクセス権と管理者権限を確認します。
    • この権限をアプリケーションに設定するには、.exeファイルを右クリックし、管理者として実行を選択します。
これらの手順を実行した後、Microsoft Officeのバージョン間の違いによりReport Generation ToolkitでVIの破損エラーが発生することがあります。これを解決するには、この記事の手順をおこなってください。

この記事はお役に立ちましたか?

いいえ