Can I Install Two Versions of LabVIEW, LabVIEW FPGA, and the NI RIO Driver Simultaneously?

Updated May 3, 2018

Reported In

Software

  • LabVIEW
  • LabVIEW FPGA Module

Driver

  • NI-RIO

Issue Details

I want to transition to a different version of LabVIEW, LabVIEW FPGA, and the NI RIO Driver. What problems can I anticipate in this process?

Solution

Essentially, yes. The only software that cannot have two versions installed are the drivers. So you need to check the corresponding driver compatibility page.

For example, if you want to have LabVIEW, LabVIEW Real Time, LabVIEW FPGA, and NI RIO Driver all installed in 2014 and 2017 versions, you would find on the NI-RIO and LabVIEW Version Compatibility that the 2017 RIO Driver, which will replace the 2014 driver, is not compatible with LabVIEW 2014. Thus, your RIO code in LabVIEW 2014 would not work properly after upgrading the RIO driver.

Additional Information

There can only be one version of our drivers. A newer driver will often, but not always, work with previous hardware. Be sure to check compatibility charts if you have any concerns about your hardware's compatibility.

WAS THIS ARTICLE HELPFUL?

Not Helpful