コンピュータ間でカスタムのLabVIEWパレットを移行する

更新しました Sep 27, 2019

使用製品

Software

  • LabVIEW

問題

LabVIEW関数パレットでVIのグループを作成して、後でカスタムツールセットとして他のLabVIEWユーザへ簡単に配布できるようにするにはどうすればよいですか?

解決策

作成されたパレットのすべてのカスタムVIを新しいフォルダに整理し、そのフォルダを<LabVIEW>\vi.libに保存する必要があります。ほとんどのユーザが使用しているLabVIEWにはこのディレクトリが存在しているため、これらのVIを保存するのに最適なディレクトリです。
 

次に、配布したいパレットに関するすべての情報を含む.mnuファイルを作成する必要があります。.mnuファイルを作成するには、LabVIEWを開いてパレットセットを編集する必要があります。
 

  1. ツール>>上級>>パレットセットを編集...に移動します。
  2. 関数パレットで、関数を追加するパレットを右クリックして、挿入>>サブパレットを選択します。
  3. 新規パレットファイル(.mnu)を作成を選択します。
  4. .mnuファイルに名前を付けて保存します。後で必要になるため、ファイルの保存場所を覚えておきます。
  5. サブパレットに名前を付けてOKを押します。
  6. 新しいサブパレットのアイコンをクリックして、パレットを右クリックし、挿入>>VI...を選択します。
  7. vi.libフォルダに移動して、カスタムVIを追加します。
  8. パレットセットへの変更を保存します。

 

移行先のコンピュータで以下の手順を行います。
 

  1. カスタムVIを含むフォルダを<LabVIEW>\vi.libにコピーします。
  2. .mnuファイルを<LabVIEW>\menus\Categoriesディレクトリにコピーします。


たとえば、.mnuファイルを<LabVIEW>\menus\Categories\Programmingにコピーすると、プログラミングパレットにカスタムのパレットが表示されます。

この記事はお役に立ちましたか?

いいえ