USB DAQ设备对Linux的支持

更新 Jul 7, 2020

适用于

司机

  • NI-DAQmx
  • NI Linux Device Drivers 2019

操作系统

  • Linux

问题详述

我购买了USB数据采集(DAQ)设备,并且希望在Linux桌面操作系统上使用它。 Linux桌面系统是否支持USB设备?如果支持,我应该安装哪个驱动程序?

解决方案

在Linux操作系统上只能使用某些USB数据采集设备。

NI-DAQmx Base确实支持某些USB DAQ设备,但不支持X系列设备 。有关最新版本的DAQmx-Base支持的USB DAQ设备的列表,请参见NI-DAQmx Base 15.0.0自述文件 。可下载的NI-DAQmx Base驱动程序的最新版本为15.0。请检查Linux和macOS的兼容性,以获取该驱动程序的受支持版本。有关更多信息,请阅读DAQmx基本驱动程序的停止更新公告 。如果使用该驱动程序将设备与LabVIEW接口,请注意,该驱动程序仅适用于LabVIEW 2012、2013、2014和2015版本。

从NI Linux设备驱动程序发布(2019年7月)开始,您可以在Linux操作系统上使用DAQmx 19.5。但是,请注意,仍不支持所有USB多功能DAQ设备。请查看DriverUpdates.zip中的README文件,以找到DAQmx 19.5支持的硬件。

相关信息

有关NI驱动程序支持的Linux发行版的列表,请参考NI Linux设备驱动程序下载页面