Why Am I Getting Error When Installing NI ELVIS Without LabVIEW

Updated Jan 25, 2018

Reported In

Hardware

  • NI ELVIS Electronics Board

Software

  • LabVIEW Base

Issue Details

Why do I need to install LabVIEW before installing NI ELVIS?

Solution

To install NI ELVIS, LabVIEW 7.0 or later must be installed on the computer.

The NI ELVIS software contains a soft front panel (SFP) instrument launcher executable that only requires the LabVIEW Run-Time Engine, but NI ELVIS also installs the NI ELVIS API (set of VIs that allow you to create customized programs using LabVIEW to control NI ELVIS). These VIs are installed within the LabVIEW directory (...\Program Files\National Instruments\LabVIEW\instr.lib folder) and thus LabVIEW will need to be installed prior to the installation of NI ELVIS.

WAS THIS ARTICLE HELPFUL?

Not Helpful