"Failed to Download" Messages from the Compact Vision System

Updated Jun 11, 2018

Reported In

Software

  • LabVIEW Full
  • Vision Development Module

Driver

  • NI-IMAQ
  • NI-IMAQdx

Issue Details

I have created an application that uses NI-IMAQ and NI-Vision VIs inside of LabVIEW Real-Time. Now I am trying to download the application to my Compact Vision System (CVS), but every time I try to download, I receive a Failed to Download message, and I am unable to run my application. How can I correct this?

Solution

When you receive a Failed to Download message when trying to download a Vision application to your CVS, it is usually because you do not have proper support software installed on the CVS. Usually when this error occurs with a Vision application it is because LabVIEW Real-Time support has not been installed with NI-Vision.
 
To correct this problem, you first need to install LabVIEW Real-Time support for NI Vision on the host computer.  To do this, you will need to modify your installation of NI-Vision to add support for this feature as described below:

1. Browse to Control Panel » Add or Remove Programs
2. Select National Instruments Software
3. Click Change.
4. In the pop up window that occurs, highlight IMAQ Vision for LabVIEW (for 7.x) or NI Vision (for 8.x)
5. Click Modify.
6. Once the installer has initialized, click through the screens until you reach the screen shown below:
 

7. When selecting the features to install, make sure to install LabVIEW Real-Time Support.

8. After selecting the feature click Next and continue through the installation process.

After the installer has completed:
  1. Go into Measurement & Automation Explorer (MAX) and install the new LabVIEW Real-Time support for NI Vision onto your Compact Vision System.
  2. Open LabVIEW (shutdown and restart if it was open during installation) and you should now be able to download your application to your CVS. 

Additional Information

If you receive another error when trying to download all of the software onto the CVS and are trying to install support for Vision Builder for Automated Inspection (VBAI) and LabVIEW 7.1 RT, then please refer to the KnowledgeBase linked below.

WAS THIS ARTICLE HELPFUL?

Not Helpful