當開啟遠端Target的FPGA參照時會出現Error -63193

更新 Nov 9, 2020

產品資訊

硬件

  • cRIO-9074
  • NI-9149
  • cRIO-9076
  • cRIO-9072
  • cRIO-9073
  • cRIO-9075
  • cRIO-9012
  • cRIO-9014
  • cRIO-9022
  • cRIO-9023
  • cRIO-9024
  • cRIO-9025

軟體

  • LabVIEW FPGA Module
  • LabVIEW 2017 Full
  • LabVIEW 2017 Professional

驅動程式

  • NI-RIO 17.0

操作系統

  • VxWorks

問題敘述

我有一台cRIO-9074和一台乙太網路RIO NI-9149。我想透過cRIO-9074上的Host VI來執行放在NI-9149上的FPGA VI。以往使用LabVIEW 2015 SP1 f10、LabVIEW FPGA Module 15.0.1、LabVIEW Real-Time 15.0.1和CompactRIO設備驅動程式15.5版時可以成功。

最近我將所有LabVIEW軟體更新至最新版本(LabVIEW 2017 f2,LabVIEW FPGA Module 17.0.0、LabVIEW Real-Time 17.0.0、CompactRIO設備驅動程式17.6)。現在每當我嘗試開啟對遠程NI-9149的FPGA參照(reference)時,就會出現Error -63193 (「The requested feature is not supported.」),並且無法執行FPGA VI。

解決方案

當前在9149以及Real-Time作業系統為VxWorks的cRIO之間,存在一個Bug。作為替代方案:
  • 請將您的軟體版本降回至最初的15.5版本系統。
  • 使用非VxWorks作業系統的其他類型cRIO控制器。