Microsoft Visual Studio 2010 및 이전 버전에서 Measurement Studio 응용 프로그램 배포

업데이트 됨 Apr 23, 2019

해당 제품

Software

  • Measurement Studio Standard
  • Measurement Studio Professional
  • Measurement Studio Enterprise

문의사항

Measurement Studio 구성 요소를 포함하는 .NET 어플리케이션을 생성하였고, 이 어플리케이션을 타겟 장비에 어플리케이션을 배포하려고합니다. 어떻게 해야 합니까?

해결책

Measurement Studio 구성 요소가 포함된 .NET 어플리케이션이 타겟 장비에서 제대로 실행 되려면 타겟 장비에 특정 Measurement Studio 구성 요소가 있어야합니다.

Microsoft Visual Studio는 설치 및 배포 프로젝트를 제공함으로써 배포를 훨씬 쉽게 만듭니다. 설치 및 배포 프로젝트를 사용하면 어플리케이션을 배포하기 위해 설치 프로그램을 만들 수 있습니다. 결과 Windows Installer ( .msi ) 파일에는 어플리케이션, 종속 파일, 레지스트리 항목과 같은 어플리케이션 정보 및 설치 지침이 들어 있습니다.

참고 : Visual Studio 2012 이상에는 설치 및 배포 프로젝트가 포함되어 있지 않습니다. Visual Studio 2012 이상을 사용하는 경우 어플리케이션을 다른 컴퓨터에 배포하려면 다른 프로세스를 필요로 합니다. NI는 새로운 설치 프로그램을 생성 할 때 Measurement Studio Installer Builder를 사용할 것을 권장합니다. Measurement Studio Installer는 Measurement Studio 2015와 함께 출시되었습니다. 설치 프로그램 빌더로 Measurement Studio 버전에 액세스 할 수 없는 경우 Windows Installer XML (WiX) Tool Set를 사용하여 Visual Studio 2012에서 설치 프로그램을 만드는 것이 좋습니다. WiX 도구 세트를 사용하여 Measurement Studio 어플리케이션을 배치하는 방법에 대한 지침은 다음 KB를 참고하시기 바랍니다: Deploying Measurement Studio Applications with WiX 

Visual Studio 2003, 2005, 2008 또는 2010을 사용하여 필요한 Measurement Studio 구성 요소가 포함된 배포 프로젝트를 만들려면 다음 단계를 수행하십시오.
  1. 기존 Visual Studio 프로젝트 또는 예제 프로그램을 엽니다. 다른 컴퓨터에 배포하려는 프로젝트여야합니다.
  2. Build»Configuration Manager로 이동하여 프로젝트의 타겟 플랫폼을 확인하십시오.

    일부 National Instruments 라이브러리는 플랫폼에 따라 다르므로 32-비트 및 64-비트 버전의 어셈블리가 별도로 제공됩니다. 기본적으로 Measurement Studio 프로젝트 유형은 32-비트 어셈블리에 대한 참조를 추가합니다. 타겟 플랫폼을 AnyCPU로 설정하고 64-비트 운영 체제에 어플리케이션을 설치하면 어플리케이션에서 64-비트 버전의 어셈블리를 로드하려고 시도하므로 32-비트만 배포한 경우 런타임 에러가 발생합니다. 이를 위한 솔루션은 대상 플랫폼을 x86 (32-비트)으로 설정하는 것입니다. 32-비트 어플리케이션은 64-비트 운영 체제에서 올바르게 실행되고 타겟을 x86으로 설정하면 어플리케이션이 올바른 어셈블리를 찾습니다.

    64-비트 어플리케이션을 만들려면 대상 플랫폼을 x64로 설정하십시오. 프로젝트의 참조를 64-비트 버전의 어셈블리를 가리키도록 바꿔야합니다. 플랫폼 별 64-비트 어셈블리는 C:\Program Files\National Instruments\MeasurementStudioVS[Visual Studio version]\DotNET\Assemblies(64-bit)\Current에 위치해 있습니다. 또한 배포 프로젝트에 64-비트 병합 모듈이 포함되어 있어야 합니다. (7단계 참조)

    참고 : 일부 National Instruments 클래스 라이브러리는 64-비트를 지원하지 않습니다. 이러한 어셈블리의 경우 프로젝트의 대상 플랫폼은 x86이어야만 합니다. 타겟 플랫폼에 대한 더 자세한 정보는Measurement Studio Help : Measurement Studio .NET 어셈블리의 64-비트 지원 (Measurement Studio Help: 64-bit Support in Measurement Studio .NET Assemblies)을 참고하십시오.
  3. 어플리케이션을 빌드하고 실행하여 에러가 없는지 확인하십시오.
  4. 기존 프로젝트 작업 공간에 설치 프로젝트 추가합니다.
    1. Add New Project 대화 상자를 엽니 다.
      • Visual Studio 2005/2008/2010 File»Add»New Project를 선택하십시오.
      • Visual Studio 2003 File»Add Project»New Project를 선택하십시오.
    2. Add New Project 대화 상자에서 다음을 수행하십시오.
      • Visual Studio 2005/2008/2010 Other Project Types»Setup and Deployment»Visual Studio Installer를 선택합니다.
      • Visual Studio 2003 Setup and Deployment Projects를 선택합니다.
    3. 템플릿 창에서 Setup Wizard를 선택하십시오.
    4. Name 창에 설치 프로그램의 이름을 지정하십시오. Setup1 이 기본 이름입니다.
    5. OK를 클릭하여 대화 상자를 닫고 설치 마법사를 시작하십시오.
    6. 설치 마법사의 첫 번째 페이지에서 Next를 클릭하십시오.
  1. Create a setup for a Windows application를 선택하고 Next를 클릭하십시오.
  2. [Name of Project] 에서 Primary Output을 선택하고 Next를 클릭하십시오.
  3. 어플리케이션에 필요한 추가 파일 (예 : 텍스트 파일, 요구 사항 설명서 또는 .ini 파일)을 추가 할 수 있습니다. 파일을 추가 할 필요가 없으면 Next를 클릭하십시오.
  4. Finish를 클릭하십시오.
  • 설치 마법사를 완료 한 후 프로그램 파일 폴더를 설치 프로그램의 대상 파일 구조에 추가하십시오. 이렇게하면 일부 대상 컴퓨터에서 에러 -2705 가 발생하는 것을 방지 할 수 있습니다.
  1. File System ([Name of Setup Project]) 창은 설치 마법사를 마친 후에 자동으로 나타납니다. 표시되지 않으면 다음 두 가지 방법 중 하나를 사용하여 File System Editor를 엽니 다. File System Editor는 대상 컴퓨터의 폴더 구조를 나타내는 표준 폴더 집합을 표시합니다.
    • 솔루션 탐색기에서 Setup1 프로젝트를 클릭하여 선택하고 View»Editor»File System으로 이동하십시오.
    • 솔루션 탐색기에서 Primary Output from [Name of Project]를 두 번 클릭하십시오.
  2. File System on Target Machine을 마우스 오른쪽 단추로 클릭하고 Add Special Folder»Program Files Folder를 선택합니다.
 
  • 솔루션 탐색기에서 Detected Dependencies을 확인하여 프로젝트의 구성 요소에 대한 모든 병합 모듈이 추가되었는지 확인하십시오. 대부분의 경우 병합 모듈은 Visual Studio에서 자동으로 검색됩니다. 그러나 경우에 따라 Visual Studio에서 이를 감지하지 못할 수 있습니다. Measurement Studio .NET Merge Modules을 참조하여 사용중인 National Instruments 라이브러리와 구성 요소에 필요한 병합 모듈(Merge Modules)을 확인하십시오. 설치 프로젝트에서 누락 된 것이 있으면 솔루션 탐색기에서 Setup1 프로젝트를 마우스 오른쪽 단추로 클릭하고 Add»Merge Module을 선택하고 필요한 파일을 찾습니다. 기본적으로, Measurement Studio는 모든 병합 모듈을 C:\Program Files\Common Files\Merge Modules 디렉토리에 설치합니다.
    • ActiveX 컨트롤을 사용하는 경우 추가 병합 모듈(Merge Modules)이 필요합니다. ActiveX 그래프, 슬라이더 또는 다른 사용자 인터페이스 컨트롤 중 하나를 사용하는 경우 CWUI_OCX.msm 추가하십시오. 3D 그래프 컨트롤을 사용하는 경우 CW3DGRAPH_OCX.msm를 추가하십시오. 이렇게하면 ActiveX 컨트롤에 필요한 모든 추가 종속성이 추가됩니다.
    • Windows 7에 배포하는 경우 MStudioUtils.msm 을 추가해야 할 수 있습니다. 자세한 내용은 다음 링크를 참고하시기 바랍니다: Why Did My Measurement Studio Distribution Not Fully Install In Windows 7?
  • Setup1 프로젝트를 마우스 오른쪽 단추로 Rebuild를 선택하십시오. 이렇게 하면 모든 종속성을 포함하는 설치 프로그램이 빌드됩니다.
  • 파일을 다른 컴퓨터에 배포하려면 Windows 탐색기를 열고 프로젝트 디렉토리로 이동 한 다음 빌드 된 설치 프로그램을 찾으십시오. Windows 7의 기본 경로는 C:\Users\[user name]\Documents\Visual Studio\Projects\[Solution Folder Name]\Setup1\[project configuration]\Setup1.msi입니다. 여기서 project configuration Debug 또는 Release 입니다.
  • Setup1.msi , Setup.exe 및 디렉터리의 다른 모든 파일과 하위 디렉터리를 대상 컴퓨터에 복사합니다.
  • 대상 컴퓨터에서 Setup.exe 를 더블 클릭하여 설치 관리자를 실행합니다. 참고 : 설치 프로그램을 실행하려면 대상 컴퓨터에 대한 설치 권한이 있어야합니다.
참고 : 어플리케이션이 NI-DAQmx, NI-VISA 또는 NI-488.2와 같은 내쇼날 인스트루먼트 하드웨어 드라이버를 사용한다면, 타겟 장비에 드라이버 자체를 설치해야합니다. 일부 드라이버의 경우 전체 드라이버를 설치하지 않으려는 경우 런타임을 설치할 수 있습니다. 예를 들어, ni.com/downloads 에서 NI-DAQmx 런타임을 다운로드 할 수 있습니다. 개발 컴퓨터에 설치된 버전과 일치하는 버전을 검색하여 설치하십시오.

Measurement Studio 어플리케이션 배치에 관한 더 자세한 정보는 Measurement Studio Help Measurement Studio Applicationss Help Topic 을 참조하십시오. Measurement Studio 통합 메뉴 항목을 통해 Visual Studio 내에서 Measurement Studio Help에 접근할 수 있습니다.

    이 글이 도움이 되셨습니까?

    도움 안됨