Measurement & Automation Explorer (MAX)의 "Unexpected Error"의 원인

업데이트 됨 Nov 5, 2018

해당 제품

Software

  • Measurement and Automation Explorer (MAX)

문의사항

Measurement & Automation Explore (MAX)를 사용하는 동안 아래와 같은 예기치 않은 오류 대화 상자가 나타납니다. 이 에러는 무엇입니까? Do not show this error again 옵션을 선택하여 무시해도 되나요?

해결책

MAX는 내부 플러그인에 의해 발생한 예외를 감지 할 수 있습니다. 예외 중 일부는 사소하여 MAX의 작동에 부정적인 영향을 미치지 않습니다.

에러를 처음으로 본 경우 컴퓨터를 먼저 다시 시작하십시오. 새로운 NI 소프트웨어를 설치하고 PC를 다시 시작하지 않아서 에러가 발생하는 경우가 종종 있습니다.

다음은 현재 알려진 예외 목록입니다. 예외가 양호하고 시스템에 부정적인 영향을 주지 않으면 에러 대화 상자에서  Do not show this error again을 선택하여 다시 표시되지 않도록 할 수 있습니다.
 
 
# 플러그인 예외사소한?
1NI-DAQmxCpcCopierProxy::GetSourceItemsIfNecessary
.nce 파일을 원격 RT ​로 반입할 때 발생할 수 있습니다. 해결하려면 NI-DAQmx 9.0 또는 그 이상으로 업그레이드 하십시오.
2niFPui.mxxCmxRSFrameworkObserver::NotifyObjectRemoving
여러 FieldPoint 타겟을 삭제할 때 발생할 수 있습니다.
3niVISAui.mxxCmxAggregateItemUI::GetPopupMenu
MAX에서 VXI Instrument를 highlight / 클릭 할 때 발생할 수 있습니다.
4imaqcfgui.mxxCmxAggregateItemUI::FinalRelease아니요
MAX가 닫혀 있을 때 발생할 수 있습니다. MAX가 4.6.2 이전에서 4.7로 업그레이드되고 NI-IMAQ가 업그레이드 되지 않으면, 이 예외가 반환됩니다. 최신 버전의 NI-IMAQ로 업그레이드 하십시오.
5niHDVUI.mxxCmxProviderWrapper::Initialize아니요
MAX를 열 때 발생할 수 있습니다. MAX가 4.6.2 이전에서 4.7로 업그레이드되고 LabVIEW DSC가 업그레이드 되지 않으면, 이 예외가 반환됩니다. 해결하려면 LabVIEW DSC 2010 또는 그 이상으로 업그레이드 하십시오.
6nipalsys.dllCmxSysExpertManager::InitializeExpert아니요
MAX를 열 때 발생할 수 있습니다. 이 예외는 실제 주소 확장을 사용하는 시스템에서 발생할 수있는 다른 오류와 함께 발생합니다. 해결하기 위해 NI Software Fails When Physical Address Extension is Enabled를 참조하십시오.
7niPXIui.mmxCMXAggregateItemUI::GetViews, CPXIObject::FindParent아니요
3.0 이전의 PXI 플랫폼 서비스 버전에서 발생할 수 있으며 PXI 섀시의 구성 일부 또는 전부를 로드 할 수 없다는 것과 관련이 있습니다. PXI Platform Services 3.0 또는 이후 버전으로 업데이트 하여 해결하십시오.

추가 정보

이 오류는 소프트웨어가 제대로 설치되지 않았거나 손상된 경우에도 발생할 수 있으며, 다시 설치하여 해결할 수 있습니다. Force Reinstall Non-Working or Corrupt NI Software 글을 따라 하거나, DAQmx 및 모든 종속성을 제거하고 재시작 한 후 소프트웨어를 설치하십시오. 소프트웨어가 제대로 설치 되지 않는 일반적인 원인은 안티 바이러스 소프트웨어이기 때문에 안티 바이러스를 비활성화하십시오.

이 에러는 실제 또는 가상의 FieldDAQ 디바이스를 사용하면서 NI-DAQmx 18.0 또는 18.1로 업그레이드 할 때 발생하는 에러와 유사합니다. NI-DAQmx 18.0 또는 18.1로 업그레이드 하고 이 문제가 발생한 경우, 이 문제를 해결하는 방법에 대한 자세한 내용은 Internal Warning when Upgrading to NI-DAQmx 18.0 or 18.1 with FieldDAQ 을 참조하십시오.

이 글이 도움이 되셨습니까?

도움 안됨