Error -61499, Internal Software Error in LabVIEW FPGA

Updated Jul 3, 2018

Reported In

Hardware

  • cRIO-9073
  • PXI FPGA Module for FlexRIO
  • PXI-7842

Software

  • LabVIEW FPGA Module

Driver

  • FlexRIO
  • NI-RIO

Issue Details

  • I am getting Error -61499: LabVIEW FPGA: An internal software error in the LabVIEW FPGA Module has occurred in an FPGA VI at compilation time or while editing a VI.
  • I get Error -61499 while editing an FPGA VI. The error refers to specific FPGA nodes, in my case, the Open FPGA VI Reference vi causes the error when I place it from the palette. 

Solution

Work through the following recommendations to resolve this error:
  • Use the Compile Cloud Service or a compile server farm.
    • If a remote compile session does not fix the issue and you have the Xilinx compile tools installed, try to uninstall the Xilinx tools before compiling.
  • Try removing and re-creating the build specification. See Working with FPGA Build Specifications for more information.
  • Try to delete and re-create the affected FPGA nodes.
  • If you are using local compilation tools, Force Reinstall the Xilinx compilation tools.
  • Force Reinstall the LabVIEW FPGA Module.
  • Force Reinstall any RIO Drivers.

Additional Information

Before LabVIEW 2018 FPGA, Xilinx compile tools were not supported on Windows 10 so if the Xilinx compile tools are installed, there could be unexpected behavior from this configuration. 

You can find download links to Xilinx tools that are compatible with your version of LabVIEW on the Compatibility between Xilinx Compilation Tools and NI FPGA Hardware web page.

WAS THIS ARTICLE HELPFUL?

Not Helpful