设置LabVIEW VI在运行模式下打开

更新 Oct 24, 2022

适用于

软件

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

操作系统

  • Windows

问题详述

我希望我的VI在打开时能够直接运行。如何配置LabVIEW VI在运行模式而不是编辑模式下打开?

解决方案

不同的 LabVIEW版本,设置方法也不同。以下是不同LabVIEW版本更改此设置的不同方法。

LabVIEW 2009及更高版本:可在VI属性中找到以运行模式打开VI的设置。您可以通过浏览至文件»VI属性»类别下拉菜单中选择执行»勾选选项列表中的打开时运行,以访问此选项,如以下屏幕快照所示。

LabVIEW 8.0:打开LabVIEW并浏览至工具»选项»环境,并勾选在运行模式下打开VI,如以下屏幕截图所示。

LabVIEW 6.x-7.x:打开LabVIEW并浏览至工具»选项»其他,并勾选在运行模式下打开VI,如以下屏幕截图所示。

相关信息

VI可通过以下方式进入运行模式:
  • 单击前面板工具栏上的“运行”“连续运行按钮
  • 单击程序框图工具栏上的“单步执行”按钮。
  • 按<Ctrl-M>或浏览操作»切换至运行模式
VI处于运行模式时,程序框图或前面板设计均不可编辑或修改。 VI处于运行模式时,某些菜单项不可用。如果希望将应用程序保持为VI格式(而不是可执行文件),但又不想让用户意外修改VI,则最好将VI设置为在运行模式下打开。