Setting LabVIEW VIs to Open in Run Mode

Updated May 3, 2018

Reported In

Software

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

Operating System

  • Windows

Issue Details

I want my VIs to be running when I open them. How do I configure my LabVIEW VIs to open up in Run Mode instead of Edit Mode?

Solution

Below you will find the different methods to change this setting according to your LabVIEW version.

LabVIEW 2009 and newer: The setting to open VIs in run mode can be found in the VI Properties. You can access this option by browsing to File » VI Properties » select Execution from the Category drop-down menu » check Run when opened from the list of options as seen in the screenshot below.

LabVIEW 8.0: Open LabVIEW and browse to Tools » Options » Environment and check/uncheck Open VIs in run mode as seen in the screenshot below.

LabVIEW 6.x - 7.x: Open LabVIEW and browse to Tools » Options » Miscellaneous and check/uncheck Open VIs in run mode as seen in the screenshot below.

Additional Information

A VI can enter Run Mode by:
  • Clicking the Run or Run Continuously buttons on the front panel toolbar
  • Clicking the Single Stepping buttons on the block diagram toolbar. 
  • Pressing Ctrl+M or browsing to Operate » Change to Run Mode
When a VI is in Run Mode, neither the block diagram or the design of the front panel can be edited or modified. Some menu items are unavailable while a VI is in Run Mode. Setting your VIs to open in Run Mode may be desirable if you want to keep the application in VI format (as opposed to an executable) but don't want the user to accidentally modify the VI.

WAS THIS ARTICLE HELPFUL?

Not Helpful