使用带有NI Real-Time的64位LabVIEW时出现不支持的项目错误

更新 Apr 1, 2024

适用于

软件

  • LabVIEW Real-Time Module
  • LabVIEW FPGA Module
  • LabVIEW

操作系统

  • Windows

问题详述

当尝试在LabVIEW 64-bit中访问我的Real-Time或CompactRIO目标时,我收到一条警告:
Unsupported Item:LabVIEW cannot currently load the selected item. The required module, driver, or plug-in either is not installed or has an expired license. Ask the creator of the item or its project what software it requires. Contact NI for help identifying the software。

解决方案

(1) FPGA 或实时模块未激活或 (2) LabVIEW开发系统、LabVIEW实时模块和/或LabVIEW FPGA模块的位数不匹配时,可能会出现此错误。
  1. 确保您的模块已在NI License Manager中正确激活
  2. 检查您正在使用的软件的位数。 LabVIEW及其使用的模块必须在位数和版本上匹配。您可以检查您正在使用的LabVIEW版本位数,并根据需要更新您的模块。
    • 您使用的LabVIEW版本和所需的模块将决定您是否可以继续使用64位软件还是应该切换到32位软件(因为并非每个LabVIEW版本都提供 64位模块)。


LabVIEW实时模块

64位LabVIEW Real-Time 模块自2021版起提供。之前的版本提供32位LabVIEW Real-Time模块。
如果您使用的LabVIEW版本早于2021年,并且需要实时模块,则必须使用LabVIEW 32位。
  • 注意: 64位LabVIEW Real-Time模块仅支持32位版本支持的部分硬件。


LabVIEW FPGA模块

64位LabVIEW FPGA 模块自2018版本起提供。之前的版本提供32位LabVIEW FPGA模块。
如果您使用的LabVIEW版本早于2018年,并且需要FPGA模块,则必须使用LabVIEW 32位。
  • 注: 64位LabVIEW FPGA模块仅支持32位版本模块所支持的部分硬件。请参阅您的FPGA模块版本的自述文件,了解该模块的64位版本中支持的硬件列表。

相关信息