LabVIEW FPGA 또는 Real-Time의 64 비트 모듈은 어디에서 찾을 수 있습니까?

업데이트 됨 May 4, 2022

해당 제품

소프트웨어

  • LabVIEW Real-Time Module
  • LabVIEW FPGA Module
  • LabVIEW

문의사항

LabVIEW 64 비트에서 Real-Time 또는 CompactRIO 타겟에 접근하려고 할 때 다음과 같은 경고 메시지가 나타납니다.
  • 지원되지 않는 아이템 : LabVIEW는 현재 선택된 아이템을 로드 할 수 없습니다. 필요한 모듈, 드라이버 또는 플러그인이 설치되지 않았거나 라이센스가 만료되었습니다. 아이템이나 프로젝트 제작자에게 어떤 소프트웨어가 필요한지 물어보십시오. 소프트웨어 식별에 도움이 필요하면 NI에 문의하십시오.
  • 64 비트 버전의 LabVIEW FPGA Module 또는 LabVIEW Real-Time Module 용 설치 프로그램을 찾을 수 없으며, 32 비트 버전의 LabVIEW 용 설치 프로그램 만 찾을 수 있습니다. 이 모듈의 64 비트 버전을 어디에서 다운로드 할 수 있습니까?

해결책

  • 현재 64 비트 버전의 LabVIEW Real-Time Module이 없습니다. Real-Time을 사용하려면 32 비트 버전의 LabVIEW가 설치되어 있어야합니다.
    • 노트 : 하드웨어에 LabVIEW Real-Time Module 지원이 필요한 경우, LabVIEW FPGA Module 32 비트를 설치하십시오.
  • LabVIEW 2017 SP1까지는 64 비트 버전의 LabVIEW FPGA Module이 없으며, 32 비트 FPGA Module을 LabVIEW 64 비트와 함께 사용할 수 없습니다. 2018 년 이전 버전의 FPGA 모듈을 사용하려면 32 비트 버전의 LabVIEW가 설치되어 있어야합니다.
  • LabVIEW FPGA Module의 64 비트 버전은 2018 년에 출시되었습니다.
    • 노트 : LabVIEW FPGA Module 64 비트는 32 비트 버전의 모듈에서 지원되는 하드웨어의 서브셋만 지원합니다. 64 비트 버전의 모듈에서 지원되는 하드웨어의 목록은 LabVIEW 2018 FPGA Module Readme 를 참조하십시오.

추가 정보

  • LabVIEW 32 비트는 LabVIEW 64 비트 버전과 병렬로 설치할 수 있습니다.
  • 64 비트 및 32 비트 버전 모두에 동일한 라이센스 Activation 키를 사용할 수 있습니다.
  • 64 비트 운영 체제에 LabVIEW 32 비트를 설치할 수 있습니다.
  • 모듈 및 필요한 드라이버 설치 순서가 중요합니다. 이 문서에서 더 자세한 정보를 찾아보십시오 : CompactRIO 시스템용 NI 소프트웨어 설치하기