Unable to Include Full IMAQdx 14 Driver Support to My Installer

Updated Jan 22, 2018

Reported In

Software

  • LabVIEW 2014 Application Builder Module

Driver

  • NI-IMAQdx 14.0

Programming Language

  • LabVIEW G

Issue Details

I want build an executable that uses NI-IMAQdx 14 Driver. When I try to build an installer for this executable, why do I not have the option to include NI-IMAQdx driver?

Solution

From VAS August 2014 to VAS February 2015, we only allowed the deployment of the runtime engine components. This gave the benefit of a significantly reduced installer size, but you could no longer include LabVIEW application development support (ADE) in the installer. The LabVIEW Run-Time Engine and NI-IMAQdx Runtime automatically selected for an installer for a vision application can be seen below.



If you need to install VAS 14.0 with ADE Support onto your deployment machine, you will need to distribute the full VAS installer on that machine in addition to LabVIEW (to make use of the VAS ADE support). To do this automatically, you would have to write a batch file to run the installer for LabVIEW and then NI-IMAQdx.

From VAS August 2015 and onwards, we added the ability to include full ADE support back. As the screenshot below shows, you can now add NI Vision Common Resources (which are the VIs that allow the ADE support).



 

Additional Information


 

WAS THIS ARTICLE HELPFUL?

Not Helpful