LabVIEW-Built Installer 오류: 이 설치에는 Windows 7 서비스 팩 1 이상이 필요합니다

업데이트 됨 Oct 15, 2019

해당 제품

Software

  • LabVIEW Application Builder Module
  • LabVIEW

Operating System

  • Windows

문의사항

LabVIEW 2016 (또는 그 이상)과 LabVIEW 2015 SP1 (또는 그 이전 버전)을 모두 설치한 개발 컴퓨터가 있습니다. 설치 프로그램을 개발할 대상 컴퓨터에 이전 Windows 운영 체제 (Windows 7 RTM, Windows Vista, Windows XP SP3 등)가 있습니다.

LabVIEW 2016은 이 운영체제와 호환되지 않으므로 이전 버전의 LabVIEW에서 설치 프로그램을 개발했습니다. 그러나 타깃 머신에서 LabVIEW에 내장된 설치 프로그램을 실행하려고 할 때 여전히 오류가 발생합니다 :

This installation requires Windows 7 Service Pack 1 or later.

해결책

LabVIEW 2016에는 다른 버전의 LabVIEW에서 공유 구성 요소로의 업그레이드가 포함되어 있습니다. 이 업그레이드는 개발 시스템에 설치된 모든 LabVIEW 버전을 LabVIEW 2016 및 이후 버전에서 지원되지 않는 운영 체제와 호환되는 설치 프로그램을 만들 수 없습니다. 이것은 Windows 7 SP1 이전의 모든 OS 버전에 영향을 줍니다.

이전 운영 체제 용 LabVIEW에서 설치 프로그램을 작성하려면 대상 컴퓨터에 설치할 수 있는 LabVIEW와 Windows의 최신 호환 버전을 확인하고 적절한 버전만 설치된 개발 컴퓨터를 사용하십시오. 

추가 정보

2016년 7월 1일 이후에 출시된 LabVIEW Development System 및 기타 NI 관련 소프트웨어의 설치에 대한 자세한 내용은 다음 링크를 참고하십시오.: NI Software Installation Requires Windows 7 Service Pack 1 or Later.
운영체제 지원 변경 사항에 대한 추가 정보는 LabVIEW readme 파일을 참조하십시오.

이 글이 도움이 되셨습니까?

도움 안됨