我可以對LabVIEW程式區進行放大或縮小嗎?

更新 May 19, 2021

產品資訊

軟體

  • LabVIEW

問題敘述

  • 我可以放大或縮小LabVIEW程式區嗎?
  • 我在高解析度率螢幕上使用LabVIEW,很難在圖表上連接功能或讀取VI label。如何更好地查看VI端口進行連線?

解決方案

LabVIEW不提供縮放功能。不過,可以進行一些操作來改善程式碼的可讀性:

  • Windows Magnifier:快捷方式Windows鍵+加號應調出放大鏡。再次按此鍵組合可放大全屏,而按Windows鍵+減號可縮小。
    • 也可以通過到Start»All Programs»Accessories»Accessibility»Ease of Access»Magnifier來使用此工具。它可以在三種模式下使用:全屏,鏡頭,以及停靠。鏡頭模式如下圖所示。有關此應用程式的更多訊息,請參考Windows文件:使用放大鏡使螢幕上的內容更易於查看
    • View As Icon:具有多個端口的subVI ,可以展開subVI以更大的格式查看輸入和輸出節點。
      1. 右鍵單擊subVI的圖標,然後取消選中View As Icon 。
      2. 然後,單擊拖動圖標的底部將展開subVI並視覺化節點。
        • 可以在接線之後將其返回View As Icon模式。

    • 降低螢幕解析度:使用作業系統的設定更改螢幕的解析度,將螢幕解析度設置為較低值會增加螢幕上顯示的所有內容的尺寸,從而使接線端口顯得更大。
      • 注意,這也會減少程式區的可見區域。如果您已經有一個大的程式區,則可能導致更加困難在程式區中導航。
    • LabVIEW Navigation Window:如要縮小以獲取程式碼概覽,可使用Navigation Window輕鬆選擇或移至要撰寫的程式碼(如果VI太大而無法容納在單個窗口中) )。在View»Navigation Window或通過按鍵盤上的<Ctrl + Shift + N>組合鍵啟動。                                       
      • :使用LabVIEW 8.6.1及更低版本時,Navigation Window功能僅在完整版和專業版中可用。

    以下操作以通過提高整體可讀性或導航來幫助視覺化:
    • 使用更多subVI :為模組化程式碼創建subVI可以減小程式區的大小,提高可讀性,提高程式碼的可維護性,並增強程式碼的可伸縮性。太大的程式區可能會使程式碼的導航和可讀性變得困難。要將一段程式碼壓縮為SubVI,只需在其周圍拖動遊標即可選擇所需的程式碼。接下來,選擇Edit»Create SubVI
    • 增加字體大小:在LabVIEW中選擇Tools»Options可以增加LabVIEW用於顯示Label的字體大小。這將啟動LabVIEW設定窗口。從Environment列表中選擇Category,然後滾動到Font部分。從字體選擇器下拉菜單中選擇預定義的字體類型。取消勾選的Use default font選項,然後選擇Font Style按鈕,調整字體大小以適合您的閱讀偏好。

    相關資訊

    注:2017年5月,NI發布了LabVIEW NXG ,它在用戶界面等方面的功能變化中包含了縮放功能!有關兩個開發環境之間差異的更多訊息,請參考LabVIEW和LabVIEW NXG比較表