LabVIEWのブロックダイアグラムを拡大または縮小することはできますか?

更新しました Nov 16, 2018

使用製品

Software

  • LabVIEW Full
  • LabVIEW Base
  • LabVIEW Professional

問題

高解像度のディスプレイを使用しており、ダイアグラム上で関数を配線することやVIラベルを読むことが困難です。LabVIEWのブロックダイアグラムを拡大または縮小することはできますか?

解決策

LabVIEWは、ズーム機能を提供していません。それでも、コードの可読性を向上させるためのオプションがいくつかあります。

  • LabVIEWナビゲーションウィンドウ: ナビゲーションウィンドウを使用すると、編集するコードを簡単に選択または移動できます(VIが1つのウィンドウに収まらない場合)。表示>>ナビゲーションウィンドウで有効にするか、キーボードの<Ctrl-Shift-N>を押してください。

メモ: LabVIEW 8.6.1以前を使用している場合、ナビゲーションウィンドウは開発システム版およびプロフェッショナル開発システム版でのみ使用可能な機能です。

 

  • Windowsの拡大鏡: ショートカットキーとしてWindowsキー+プラス記号を押して、拡大鏡を表示する必要があります。 このキーコンボをもう一度押すとフルスクリーンが拡大され、Windowsキー+マイナス記号でズームアウトされます。
​このツールは、スタート>>すべてのプログラム>>アクセサリ>>アクセシビリティ>>簡単操作»拡大鏡からアクセスすることもできます。 フルスクリーンモード、カーソルに付いた拡大鏡、画面上の固定位置にあるウィンドウで使用できます。 カーソルに付いているモードを下図に示します。このアプリケーションの詳細については、Windowsのドキュメント、Use Magnifier to make things on the screen easier to seeを参照してください。

 

  • フォントサイズを大きくする: VIラベルの可読性を向上させるために、ラベル表示で使用するフォントサイズを大きくすることができます。これを行うには、LabVIEWでツール>>オプションを選択します。これにより、LabVIEWオプションウィンドウが起動します。カテゴリリストから環境を選択し、フォントセクションまでスクロールダウンします。フォント選択ドロップダウンメニューから定義済みのフォントタイプを選択します。デフォルトのフォントを使用オプションのチェックを外して、フォントスタイルボタンを選択します。表示の好みに合わせてフォントサイズを調整します。

 

  • 画面の解像度を下げる: 画面の解像度を低い値に設定すると、画面に表示されるすべてのサイズが大きくなりますが、ブロックダイアグラムの可視領域も小さくなります。オペレーティングシステムのオプションを使用して画面の解像度を変更します。

追加情報

開発者がズームアウト機能の必要性を感じるときには、この必要性の根本原因を改善するためのより良い方法があります。

  • より多くのSubVIを使用する: モジュールセクションのためにサブVIを作成すると、ブロック図のサイズが小さくなり、可読性とコード保守性、およびコードのスケーラビリティが向上します。ブロックダイアグラムが大きすぎると、コードの可読性や表示領域の移動が難しくなります。コードの一部をサブVIに集約するには、対象のコードをドラッグで選択します。次に、編集>>選択範囲をサブVIに変換を選択します。詳細は、subVIs tutorialを参照してください。

 

  • アイコンとして表示: 多くの端子を持つサブVIの場合、サブVIをアイコンとして表示と見やすくなります。サブVIのアイコンを右クリックし、アイコンとして表示を選択します。次に、サブVIのアイコンの一番下にある小さな青色の四角形をクリックしてドラッグし、名前付きの入出力端子を展開します。



メモ: LabVIEW NXGを使用する場合は、ソフトウェアに付属のヘルプを参照してください。2017年5月23日、ナショナルインスツルメンツでは、LabVIEW NXG 1.0を発表しました。これは、エディタのマイクロインタラクション、ベクトルグラフィックスに基づくユーザインタフェースオブジェクト、およびズーム機能などプログラミングの生産性を向上させる機能を搭載した次世代製品です。 LabVIEWとLabVIEW NXGの相違点の詳細については、LabVIEWメインWebサイトを参照してください。

この記事はお役に立ちましたか?

いいえ