Can I Zoom In or Out in the LabVIEW Block Diagram?

Updated Feb 10, 2021

Reported In

Software

  • LabVIEW

Issue Details

  • Can I zoom in or out on a LabVIEW block diagram?
  • I am using LabVIEW on a high-resolution display screen, and it is difficult to wire functions on the diagram or read VI labels. How can I better see the VI terminals for wiring?

Solution

LabVIEW does not provide innate zoom functionality. However, there are several things that you can do to improve the visualization of your code:
 

  • Windows Magnifier: The shortcut Windows Key + Plus Sign should bring up the magnifier. Press this key combo again to zoom in full screen, and Windows Key + Minus Sign to zoom out.
    • This tool can also be accessed by navigate to Start»All Programs»Accessories»Accessibility»Ease of Access»Magnifier. It can be used in fullscreen mode, as a magnifying glass attached to your cursor, and a window at a fixed position on the screen. The mode attached to cursor is demonstrated in the picture below. Refer to the Windows documentation for more information on this application: Use Magnifier to make things on the screen easier to see

 
    • View As Icon: For subVIs with many terminals, you can expand the subVI to view the input and output nodes in a larger format. 
      1. Right click on the subVI's icon and uncheck View As Icon.
      2. Then, click and drag the bottom of the resulting icon to expand the subVI and visualize the nodes.
        • Optionally, you can return it to View As Icon mode after wiring.


     

    • Decrease screen resolution: Setting the screen's resolution to a lower value will increase the size of everything shown on the screen, making wiring terminals appear bigger. Use your operating system's options to change a screen's resolution. 
      • Note that this will also reduce the visible area of a Block Diagram. If you already have a large block diagram this could lead to more difficulty navigating within your diagram. 
     
    • LabVIEW Navigation Window: If you want to zoom out to get an overview of the code, you can use the Navigation Window to easily select or move to the code that you want to edit (if the VI is too large to fit into a single window). Activate in View»Navigation Window or by pressing <Ctrl+Shift+N> on your keyboard.
      • Note: When using LabVIEW 8.6.1 and earlier, the Navigation Window is a feature only available in the Full and Professional versions.

    The next options may help visualization by improving general readability or navigation:
    • Use more SubVIs: Creating SubVIs for modular sections of code reduces the block diagram size, increases readability, improves code maintainability, and enhances code scalability. Overly large block diagrams can make navigation and readability of code difficult. To condense a section of code into a SubVI, simply select the desired code by dragging you cursor around it. Next, select Edit»Create SubVI.
    • Increase font size: You can increase the font size LabVIEW uses to display labels. To do this, in LabVIEW select Tools»Options. This will launch the LabVIEW options window. Select Environment from the Category list and scroll to the Font section. Select the predefined font type from the font chooser drop-down menu. Uncheck the Use default font option and select the Font Style button. Adjust the font size to suit your viewing preferences.

    Additional Information

    In May 2017, NI announced LabVIEW NXG, which, among other user interface changes, introduces zoom capabilities! Refer to LabVIEW and LabVIEW NXG Comparison tables for more information about the differences between the two development environments.