Can I Zoom In or Out in the LabVIEW Block Diagram?

Updated Mar 30, 2018

Reported In

Software

  • LabVIEW Full
  • LabVIEW Base
  • LabVIEW Professional

Issue Details

I am using a high resolution display screen, and it is difficult to wire functions on the diagram or read VI labels. Can I zoom in or out on a LabVIEW block diagram?

Solution

LabVIEW does not provide zoom functionality. Nevertheless, there are several options for improving the readability of your code:

 

  • LabVIEW Navigation Window: Use the Navigation Window to easily select or move to the code that you want to edit (if the VI is too large to fit into a single window). Activate in View»Navigation Window or by pressing <Ctrl+Shift+N> on your keyboard.

Note: When using LabVIEW 8.6.1 and earlier, the Navigation Window is a feature only available in the Full and Professional versions.

 

  • Windows Magnifier: The shortcut Windows Key + Plus Sign should bring up the magnifier. Press this key combo again to zoom in full screen, and Windows Key + Minus Sign to zoom out.
​This tool can also be accessed by navigate to Start»All Programs»Accessories»Accessibility»Ease of Access»Magnifier. It can be used in fullscreen mode, as a magnifying glass attached to your cursor, and a window at a fixed position on the screen. The mode attached to cursor is demonstrated in the picture below. Refer to the Windows documentation for more information on this application: Use Magnifier to make things on the screen easier to see

 

  • Increase font size: To increase the readability of VI labels, you can increase the font size LabVIEW uses to display these labels. To do this, in LabVIEW select Tools»Options. This will launch the LabVIEW options window. Select Environment from the Category list and scroll to the Font section. Select the predefined font type from the font chooser drop-down menu. Uncheck the Use default font option and select the Font Style button. Adjust the font size to suit your viewing preferences.

 

  • Decrease screen resolution: Setting the screen's resolution to a lower value will increase the size of everything shown on the screen but also reduce the visible area of a Block Diagram. Use your operating system's options to change a screen's resolution.

Additional Information

When developers feel the need for a zoom-out function there are often better ways to remedy the root-cause for this need:
 

  • Use more SubVIs: Creating SubVIs for modular sections of code reduces the block diagram size, increases readability, improves code maintainability, and enhances code scalability. Overly large block diagrams can make navigation and readability of code difficult. To condense a section of code into a SubVI, simply select the desired code by dragging you cursor around it. Next, select Edit»Create SubVI. Refer to the subVIs tutorial for more information.

 

  • View As Icon: For subVIs with many terminals, not showing the subVI as an icon can help when wiring, especially for those with many terminals. Right click on the subVI's icon and select View As Icon. Then, click and drag the small blue square at the bottom of the subVI's icon to expand which inputs are named.



Note: When using LabVIEW NXG, please refer to the Help included in your software. On May 23, 2017 National Instruments announced LabVIEW NXG 1.0, which introduces a re-engineered editor which improves programming productivity by streamlining the editor micro-interactions, user interface objects based on vector graphics and zooming capabilities. Refer to the LabVIEW main website for more information about the differences between LabVIEW and LabVIEW NXG.

WAS THIS ARTICLE HELPFUL?

Not Helpful