Creating an Application Distribution in LabVIEW 8.0 or Later

Updated May 3, 2018

Reported In

Software

  • LabVIEW Full
  • LabVIEW Base
  • LabVIEW Professional
  • LabVIEW Application Builder Module

Issue Details

I am trying to create an application distribution but I no longer have the Save With Options... item that I used to.  How do I create an application distribution in LabVIEW 8.0 or later?

Solution

Previous to LabVIEW 8.0, the file menu contained a Save With Options... item which allowed a user to create application distributions. 

An application distribution is a source distribution (directory of VIs) that can be executed in a run-time engine environment. That means it includes all necessary VIs from vi.lib, which come with LabVIEW development versions but not the run-time engine. Once an application distribution is created, we recommend that you do not open and modify it from a development system, due to the confusion of having multiple copies of identical vi.lib VIs. There are two similar methods to create an application distribution in LabVIEW 8 or later:

If you are looking to create a source distribution that will allow another LabVIEW user on another machine to edit and run your code, see this knowledge base article on creating LLBs

Creating application distribution, no project created yet
  1. Make sure your VIs are saved.
  2. Choose File»Save As...
  3. In the Save As dialog select Duplicate hierarchy to new location and click Continue...
  4. In the Build Source Distribution dialog choose a location for the project. Click Continue if you agree with the suggested path.
  5. A project window opens, followed by the My Source Distribution Properties dialog. In the Distribution Settings page, select the Single Destination packaging option.
  6. Uncheck Exclude vi.libExclude instr.lib, and Exclude user.lib
  7. Enter the path of where you want to save your application distribution into the Destination path field. Make sure it ends with .llb. When you do, a warning dialog asks you if you want to continue. Click Yes.
  8. Check the Destination is LLB box.  A warning dialog will ask you if you want to continue. Click Yes.
  9. The LabVIEW 7.1 application distribution also removed the block diagrams. You can do this by clicking Customize VI Settings on the Source File Settings page.
  10. Click Build. If any of your VIs were unsaved, a dialog will come up announcing that they will be saved. Click OK to save them.
  11. When the Build status dialog shows Build Complete, your source/application distribution has been created. Click Done.

For more information about Build Specification refer to the LabVIEW Help by going to Help»Search the LabVIEW Help in LabVIEW. Either search the help for build specification or in LabVIEW under Contents go to Fundamentals»Organizing and Managing a Project»Concepts»Using Build Specifications.

WAS THIS ARTICLE HELPFUL?

Not Helpful