如何创建一个自动包含所有子VI的LabVIEW VI库?

更新 Nov 17, 2018

适用于

Software

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

问题详述

我需要发布一个包含多个子VI的LabVIEW程序,所以我想要一种简单的方法来创建一个包含所有必要文件的库(扩展名为.llb)。当我选择File»Save As然后选择New VI Library时 ,库只生成一个不包含任何子VI的主VI。有没有办法自动将这些子VI包含在库中?

解决方案


有一种简单的方法可以将所有VI打包到LabVIEW VI Library(llb)文件中。执行以下步骤以将所有VI和子VI添加到一个库文件中:

LabVIEW 8.x及以上版本

1.选择文件»另存为...以打开另存为对话框窗口。
2.单击“将层次结构复制到新位置”旁边的项目符号(注意:此选项仅在您保存的VI包含子VI时才可用)。   

3.在“ 选择目录或LLB”窗口中单击“ 新建LLB

4.输入LLB的名称,然后单击“ 创建”


 

LabVIEW 7.x.

  1. 转到文件»使用选项保存,打开使用选项保存窗口。
  2. 单击Development Distribution旁边的项目符号。
  3. 如果您希望在没有安装LabVIEW及的vi.lib文件的计算机上创建一个库来使用独立应用程序,请选中Include vi.lib文件旁边的复选框。 这将保存程序中的所有VI,包括那些内置的VI。 (注意:这会将窗口左侧的项目符号更改为自定义保存 。)
  4. 如果要保存VI和子VI而不保留其程序框图,确保用户无法修改它们,请选择“ 移除框图选项。如果需要为不同平台或版本的LabVIEW重新编译VI,请不要选择此选项。因为如果没有框图,您将无法重新编译VI。
  5. 单击保存

相关信息

这将创建一个.llb文件,包含程序中使用的所有VI和子VI。您现在把这些VI变成了一个易于发布的文件。对库中的VI保存更改要比对单个VI保存更改花费更长的时间,因为操作系统必须将更改写入更大的文件中。对大型库保存更改也会增加内存需求且会降低性能。所以尝试将每个库的大小限制为大约1 MB。

以下列表描述了将VI保存为库的优点:

  • 最多可以使用255个字符来命名文件(注意:MAC OS 9.x或更早版本最高限制为31个字符)。
  • 您可以更轻松地将VI库传输到其他平台,而不是传输多个单独的VI。
  • 您可以稍微减少项目的文件大小,因为VI库是经过压缩的,可以减少对磁盘空间需求。
  • 您可以将库中的一些VI标记为顶层VI,当您打开库时,LabVIEW会自动打开该库中的所有顶层VI。

注意:如果您拥有NI LabVIEW专业开发系统并安装了必要的组件,那么您也可以在“工具”菜单下创建共享库(DLL)。有关详细信息,请参阅LabVIEW帮助文件。

本文是否有帮助?

无帮助