모든 SubVI를 자동으로 포함하는 LabVIEW VI 라이브러리를 어떻게 만듭니까?

업데이트 됨 Dec 7, 2018

해당 제품

Software

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

문의사항

여러 subVI가 포함 된 LabVIEW 프로그램을 배포 해야하므로, 모든 필요한 파일을 포함하는 라이브러리 (확장명 .llb 포함)를 만드는 쉬운 방법을 원합니다. 파일»다른 이름으로 저장  한 후  새 VI 라이브러리 로 선택하면, 라이브러리는 subVI를 포함 하지 않고 메인 VI 만 포함됩니다. 라이브러리에 다른 VI를 자동으로 포함시키는 방법이 있습니까?

해결책

모든 VI를 LabVIEW VI 라이브러리 (llb) 파일에 쉽게 패키징 할 수 있습니다. 모든 VI와 SubVI를 하나의 라이브러리 파일에 추가하려면 다음 단계를 수행하십시오 :

 

  • LabVIEW 8.x 이상

1. 파일(File)»다른 이름으로 저장 ... (Save As...)을 선택하여 다른 이름으로 저장(Save as) 대화 상자를 엽니 다.
2. 새 경로에 계층구조 복제(Duplicate hierarchies to new location) 옆에 있는 글 머리 기호를 클릭하십시오 (참고 :이 옵션은 저장중인 VI에 subVI가있는 경우에만 사용할 수 있습니다).   


 

3. 새로운 LLB(New LLB)에 디렉토리 또는 LLB 창(Choose a Directory or LLB)을 선택합니다.


 

4. LLB의 이름을 입력하고 생성(Create)을 클릭 하십시오.

 

  • LabVIEW 7.x
  1. 파일(File)»옵션으로 저장(Save with Options) 을 클릭하면 옵션으로 저장 창이 열립니다.
  2. 개발 배포(Development Distribution) 옆에 있는 글 머리 기호를 클릭하십시오.
  3. 만약 자체 LabVIEW 설치 파일 그리고 vi.lib 파일을 가지고 있지 않는 컴퓨터에서 사용되는 Stand-alone 어플리케이션에서 라이브러리를 만들기를 원한다면, vi.lib 파일 포함(Include vi.lib files) 옆에 체크 표시를하십시오 . 이렇게 하면 내장 된 VI를 포함하여 프로그램의 모든 VI가 저장됩니다. (참고 : 이렇게하면 창의 왼쪽에있는 글 머리 기호가 사용자 정의로 저장(Custom save)로 변경 됩니다.)
  4. 블록 다이어그램없이 VI와 SubVI를 저장하여 사용자가 수정할 수 없도록 하려면, 다이어그램 제거(Remove Diagrams) 옵션을 선택 하십시오. 다른 플랫폼이나 다른 버전의 LabVIEW에서 VI를 다시 컴파일해야하는 경우, 이 옵션을 선택하지 마십시오. 블록 다이어그램없이 VI를 다시 컴파일 할 수는 없습니다.
  5. 저장(Save)을 클릭 하십시오.

추가 정보

위 방법으로 프로그램에서 사용 된 모든 VI와 subVI가 포함 된 .llb 파일이 생성됩니다. 이제 이 모든 것을 하나의 파일로 쉽게 배포 할 수 있을 것입니다. 운영 체제가 더 큰 파일에 변경 사항을 기록 해야하므로 개별 VI에 대한 변경 사항을 저장하는 것보다 라이브러리의 VI에 변경 사항을 저장하는 것이 더 오래 걸립니다. 큰 라이브러리에 대한 변경 사항을 저장하면 메모리 요구 사항이 증가하고 성능이 저하 될 수 있습니다. 각 라이브러리의 크기를 약 1MB로 제한하십시오. 

다음리스트는 VI를 라이브러리로 저장하는 이점을 설명합니다 :

  • 파일의 이름은 최대 255 자까지 사용할 수 있습니다 (주 : MAC OS 9.x 이전 버전에서는 31 자로 제한됩니다).
  • 여러 개의 개별 VI를 전송할 수 있는 것보다 더 쉽게 VI 플랫폼을 다른 플랫폼으로 전송할 수 있습니다.
  • VI 라이브러리가 압축되어 디스크 공간 요구 사항을 줄이므로 프로젝트의 파일 크기를 약간 줄일 수 있습니다.
  • 라이브러리의 VI를 최상위 레벨로 표시 할 수 있으므로 라이브러리를 열 때 LabVIEW는 해당 라이브러리의 모든 최상위 레벨 VI를 자동으로 엽니 다.

참고 : NI LabVIEW Professional Development System이 있고 필요한 구성 요소를 설치 한 경우 도구 메뉴에서 공유 라이브러리 (DLL)를 생성 할 수도 있습니다. 자세한 정보는 LabVIEW 도움말 파일을 참조하십시오.

이 글이 도움이 되셨습니까?

도움 안됨