すべてのサブVIを自動的に含むLabVIEW VIライブラリを作成するにはどうすればよいですか?

更新しました Nov 23, 2018

使用製品

Software

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

問題

いくつかのサブVIを含むLabVIEWプログラムを配布する必要があるため、すべての必要なファイルを含むライブラリ(拡張子が.llb)を簡単に作成したいです。ファイル>>名前を付けて保存を選択し、次に新しいVIライブラリを選択すると、ライブラリにはサブVIのないメインVIのみが含まれます。ここに他のVIを自動的にライブラリに含める方法はありますか?

解決策

簡単にすべてのVIをLabVIEW VIライブラリ(llb)ファイルにパッケージングする方法があります。すべてのVIとサブVIを1つのライブラリファイルに追加するには、次の手順を行います。
 

LabVIEW 8.x以降

  1. ファイル>>別名で保存...を選択して別名で保存ダイアログウィンドウを開きます。
  2. VI階層の複製を別の場所に保存オプションを選択して継続...ボタンをクリックします(メモ: このオプションは、保存するVIにサブVIがある場合にのみ使用できます)。


     
  3. ディレクトリまたはLLBを選択ウィンドウで新規LLB...ボタンをクリックします。  


     
  4. LLBの名前を入力し、作成ボタンをクリックします。

  
 

LabVIEW 7.x

  1. ファイル>>オプション付きで保存を選択すると、オプション付きで保存ウィンドウが開きます。
  2. 開発配布オプションをクリックします。
  3. LabVIEWとお使いのvi.libファイルがインストールされていないコンピュータで使用するスタンドアロンアプリケーションで使用するライブラリを作成する場合は、vi.libファイルを含むの横にチェックを入れます。これにより、ビルトインVIを含むすべてのVIがプログラムに保存されます。(メモ: これは、ウィンドウの左側にある箇条書きをカスタムセーブに変更します)。
  4. ブロックダイアグラムなしでVIおよびサブVIを保存して、ユーザがそれらを変更できないようにするには、ダイアグラムを削除オプションを選択します。別のプラットフォームまたはバージョンのLabVIEWでVIを再コンパイルする必要がある場合は、このオプションを選択しないでください。VIをブロックダイアグラムなしで再コンパイルすることはできません。
     
  5. 保存をクリックします。

追加情報

これにより、プログラムで使用されたすべてのVIとサブVIを含む.llbファイルが作成されます。これですべてが1つのファイルになり、そのファイルを簡単に配布できます。オペレーティングシステムが変更を大きなファイルに書き込む必要があるため、ライブラリ内のVIに変更を保存する時間は個々のVIの変更を保存するよりも長くなります。大きなライブラリに変更を保存すると、メモリ要件が増加し、パフォーマンスが低下する可能性があります。各ライブラリのサイズを約1 MBに制限してください。

以下のリストは、VIをライブラリとして保存する利点を示しています。
 

  • ファイル名には、最大255文字まで使用できます(メモ: MAC OS 9.x以前では31文字に制限されています)。
  • 複数の個々のVIを転送するよりも簡単にVIライブラリを他のプラットフォームへ転送できます。
  • ディスク容量の要件を減らすため、VIライブラリを圧縮してプロジェクトのファイルサイズをわずかに減らすことができます。
  • ライブラリ内のVIを最上位にマークすることができます。ライブラリを開くと、そのライブラリ内の最上位VIが自動的に開きます。


メモ: LabVIEWプロフェッショナル開発システムをお持ちで、必要なコンポーネントをインストールしている場合は、ツールメニューから共有ライブラリ(DLL)を作成することもできます。詳細については、LabVIEWヘルプファイルを参照してください。

この記事はお役に立ちましたか?

いいえ