SignalExpress에서 데이터 반입하기와 반출하기

업데이트 됨 Jan 23, 2019

해당 제품

Software

  • SignalExpress 2.5.1
  • SignalExpress 2015

Operating System

  • Windows

문의사항

SignalExpress에서 파일로부터 데이터를 읽거나 데이터를 파일에 저장하려면 어떻게 해야합니까?

해결책

SignalExpress를 사용하면 여러 가지 방법으로 파일에서 데이터를 읽고 파일에 데이터를 저장할 수 있습니다. 데이터를 정의하는 방법에 따라 다양한 방법과 파일 형식이 있습니다. SignalExpress의 도움말에는 각기 다른 파일 타입으로부터 어떻게 데이터를 불러오고 반출하는지 설명되어 있습니다.
 

데이터 반입하기

  • SignalExpress 프로젝트로부터 로깅된 신호 :
다른 SignalExpress 프로젝트 파일에서 로깅된 신호를 프로젝트로 가져올 수 있습니다. File»Import»Import Logged Signals From Another Project 를 선택하여 로깅 된 데이터를 가져올 프로젝트 파일을 선택하십시오. SignalExpress는 지정된 프로젝트의 모든 기록 된 데이터를 Logged Data 창에 추가합니다.
 
  • TDMS 파일에 로깅된 신호 :
SignalExpress에서 이전에 생성한 TDMS 파일에서 로깅된 신호를 가져올 수도 있습니다. SignalExpress TDMS 파일이 들어있는 폴더로 이동하려면 File»Import»Import Logged Signals From SignalExpress TDMS Files를 선택하십시오 . Current Folder 를 선택하여 데이터를 추가하십시오. SignalExpress는 Logged Data 윈도우에 각 TDMS 데이터의 로그된 파일을 추가합니다.
 
  • ASCII 텍스트, LVM, SPICE, PSpice 및 Multisim 파일 :
SignalExpress로 파일을 가져 오려면 Add step의 "Load/Save Signals"메뉴를 사용하여 ASCII 텍스트, LVM, SPICE, PSpice 및 Multisim 파일에서 신호를 불러올 수 있습니다. 데이터를 가져온 후에는 데이터를 다른 단계의 입력 신호로 사용할 수 있습니다.
 

데이터 반출하기

다음과 같은 방법으로 신호 또는 값을 SignalExpress에서 파일로 저장하거나 반출할 수 있습니다 :
  • step에 있는 출력을 마우스 우클릭하고 바로 가기 메뉴에서 Save Value를 선택하여 신호 또는 값을 텍스트 파일에 저장합니다.
  • step에 있는 출력을 마우스 우클릭하고 바로 가기 메뉴에서 Copy Value를 선택하여 데이터를 클립 보드에 복사합니다. Microsoft Excel에 데이터를 붙여 넣을 수 있습니다.
    • 이 방법을 사용할 때 Logged Data Window의 크기를 늘려서 기록되는 데이터의 양을 늘릴 수 있습니다.
  • Microsoft Excel을 열고 출력을 Excel 워크 시트로 끌어옵니다.
  • 단계 또는 일련의 단계가 실행을 완료 한 후 "ASCII / LVM에 저장"단계를 사용하여 신호 또는 값을 텍스트 파일에 씁니다.
  • SignalExpress 데이터 로깅 기능을 사용하여 신호 로그를 TDMS 파일 형식으로 생성하십시오.
  • "Logged Data"창에서 기록 된 신호를 마우스 오른쪽 단추로 클릭하고 Convert to ASCII 옵션을 선택하여 기록 된 데이터를 ASCII 형식으로 저장하십시오.
  • "로깅"범주 아래의 Tools»Options 에서 Automatically export log file to ASCII file을 활성화합니다. 이렇게 하면 로그 파일을 만든 후 로그 파일을 ASCII 파일로 내 보냅니다.
Save to ASCII / LVM step을 사용할 때, SignalExpress는 신호 및 값을 LabVIEW 측정 데이터 파일 형식으로 저장합니다. 이 형식은 스프레드 시트 응용 프로그램 또는 텍스트 편집 응용 프로그램에서 열 수있는 탭 구분 텍스트 파일입니다. Microsoft Excel로 데이터를 내보낼 때 여러 채널의 데이터가 다른 워크 시트로 자동으로 나뉘어집니다. Excel에서 탭으로 구분 된 데이터를 한 시트에 표시하려면 데이터를 텍스트 파일에 저장 한 다음 해당 텍스트 파일을 Excel에서 엽니다. 이 파일 포맷에 대한 더 자세한 정보는 "Specification for the LabVIEW Measurement File (.lvm)"를 참조하십시오.

참고 : 데이터 반출은 데이터 로깅과 다릅니다. 데이터 로깅은 측정을 기록, 저장 및 분석하는 데 사용됩니다. 데이터 반출은 ASCII 텍스트 편집기, Microsoft Excel 또는 DIAdem과 같은 다른 응용 프로그램에서 로깅된 데이터를 보기 위한 것을 의미합니다.

이 글이 도움이 되셨습니까?

도움 안됨