SignalExpressでデータをインポートおよびエクスポートする

更新しました Jan 22, 2019

使用製品

Software

  • SignalExpress 2.5.1
  • SignalExpress 2015

Operating System

  • Windows

問題

SignalExpressでファイルからデータを読み取る、またはファイルにデータを保存するにはどうずればよいですか?

解決策

SignalExpressを使用すると、ファイルからデータを読み取り、データをいくつかの方法でファイルに保存できます。どのようにデータを定義するかによって、さまざまな方法とファイル形式があります。 SignalExpress Helpでは、さまざまなファイルタイプからデータをインポート(ロード)およびエクスポート(保存)する方法について説明しています。

 

データをインポートする:

  • SignalExpressプロジェクトから記録された信号:
別のSignalExpressプロジェクトファイルから、記録された信号をプロジェクトにインポートすることができます。 ファイル>>インポート>>別のプロジェクトから記録された信号をインポートを選択して、記録データをインポートするプロジェクトファイルを選択します。SignalExpressは、指定されたプロジェクトのすべての記録データを記録データウィンドウに追加します。
 
  • TDMSファイルから記録された信号:
また、以前にSignalExpressで作成したTDMSファイルからログに記録された信号をインポートすることもできます。ファイル>>インポート>>SignalExpress TDMSファイルから記録された信号をインポートするを選択して、SignalExpressのTDMSデータを含むフォルダに移動します。現在のフォルダを選択してデータを追加します。SignalExpressは、TDMSデータを記録データウィンドウに別の記録として追加します。
 
  • ASCIIテキスト、LVM、SPICE、PSpice、およびMultisimファイル:
SignalExpressにファイルをインポートするには、「信号をロード/保存」メニューの手順を使用します。ASCIIテキスト、LVM、SPICE、PSpice、およびMultisimファイルから信号をインポートできます。データをインポートした後、そのデータを他のステップの入力信号として使用できます。
 


 

データをエクスポートする:

SignalExpressでファイルに値を保存、または信号をエクスポートするには、次の方法があります。

 
  • ステップ上の出力を右クリックし、ショートカットメニューから値を保存を選択して、信号または値をテキストファイルに保存します。
  • ステップ上の出力を右クリックし、ショートカットメニューから値をコピーを選択して、データをクリップボードにコピーします。データをMicrosoft Excelに貼り付けることができます。
  • Microsoft Excelを起動して、出力をExcelワークシートにドラッグします。
  • ステップまたは一連のステップの実行が完了した後に、テキストファイルに信号または値を書き込むには、「ASCII/LVMに保存」ステップを使用します。
  • SignalExpressデータロギング機能を使用して、信号のログをTDMSファイル形式で作成します。
  • 記録データウィンドウでログされた信号を右クリックし、ASCIIに変換オプションを選択して、記録されたデータをASCII形式で保存します。
  • 「ログ」カテゴリのツール>>オプションにあるログファイルをASCIIファイルに自動的にエクスポートするオプションを有効にします。ログファイルの作成後、ログファイルがASCIIファイルにエクスポートされます。

ASCII/LVMに保存ステップを使用すると、SignalExpressは信号と値をLabVIEW測定データファイル形式で保存します。これはタブ区切りのテキストファイルで、スプレッドシートアプリケーションまたはテキストエディタアプリケーションで開くことができます。データをMicrosoft Excelにエクスポートすると、複数のチャンネルデータが自動的に別々のワークシートに配置されます。Excelでタブ区切りのデータを1つのシートに表示するには、データをテキストファイルに保存し、そのテキストファイルをExcelで開きます。このファイル形式の詳細については、「LabVIEW測定ファイル(.lvm)の仕様」アプリケーションノートを参照してください。



メモ: データのエクスポートは、データロギングと同じではありません。データロギングは、測定値の記録、保存、解析に使用されます。データのエクスポートは、ASCIIテキストエディタ、Microsoft Excel、またはDIAdemなどの別のアプリケーションでログに記録されたデータを表示する手段です。

この記事はお役に立ちましたか?

いいえ