Importing and Exporting Data in SignalExpress

Updated Jun 14, 2018

Reported In

Software

  • SignalExpress 2.5.1
  • SignalExpress 2015

Operating System

  • Windows

Issue Details

How do I read data from a file or store data to a file in SignalExpress?

Solution

SignalExpress allows you to read data from a file and store data to files in several ways. There are different methods and file formats depending on how you would like to define your data. The SignalExpress Help describes how to import (load) and export (save) data from different file types:

Importing Data:
  • Logged signals from a SignalExpress project:
You can import logged signals into a project from another SignalExpress project file. Select File»Import»Import Logged Signals From Another Project to select a project file from which you want to import logged data. SignalExpress adds all logged data from the specified project into the Logged Data window. 
  • Logged signals from TDMS files:
You also can import a logged signal from a TDMS file you previously created in SignalExpress. Select File»Import»Import Logged Signals From SignalExpress TDMS Files to navigate to a folder containing SignalExpress TDMS data. Select Current Folder to add the data. SignalExpress adds the TDMS data as a separate log in the Logged Data window.
  • ASCII text, LVM, SPICE, PSpice, and Multisim files:
Use the steps in the "Load/Save Signals" menu to import files into SignalExpress. You can import signals from ASCII text, LVM, SPICE, PSpice, and Multisim files. After you import data, you can use the data as an input signal for other steps.

Exporting Data:

You can save or export a signal or value to a file in SignalExpress in the following ways: 
  • Right-click an output on a step and select Save Value from the shortcut menu to save the signal or value to a text file.
  • Right-click an output on a step and select Copy Value from the shortcut menu to copy the data to the clipboard. You can paste the data into Microsoft Excel.
    • When using this method you can increase the amount of data recorded by increasing the size of the logged data window.
  • Open Microsoft Excel and drag the output to an Excel worksheet.
  • Use the "Save to ASCII/LVM" step to write signals or values to a text file after a step or series of steps completes execution.
  • Use SignalExpress data logging features to create logs of your signals in the TDMS file format.
  • Right click a logged signal in the "Logged Data" window and select the Convert to ASCII option to save logged data in the ASCII format.
  • Enable the Automatically export log file to ASCII file option in Tools»Options under the "Logging" category. This will export the log file to an ASCII file after the log file's creation.
When you use the Save to ASCII/LVM step, SignalExpress saves signals and values in the LabVIEW measurement data file format, which is a tab-delimited text file you can open with a spreadsheet application or a text-editing application. When you export the data to Microsoft Excel, data from multiple channels are automatically placed in separate worksheets. If you want to view the tab-delimited data in Excel on one sheet, save the data to a text file, then open that text file in Excel. Refer to the "Specification for the LabVIEW Measurement File (.lvm)" application note for more information about this file format.

Note: Exporting data is not the same as data logging. Data logging is used to record, save and analyze measurements. Exporting data is a means to view logged data in another application like an ASCII text editor, Microsoft Excel, or DIAdem.

WAS THIS ARTICLE HELPFUL?

Not Helpful