在LabVIEW中加载.NET 2.0,3.0和3.5程序集

更新 Nov 9, 2018

适用于

Software

  • LabVIEW Full

问题详述

已使用.NET Framework 2.0,3.0或3.5创建了.NET程序集,但是当我尝试在构造函数节点中加载这些程序集时,我却收到LabVIEW消息显示: 所选文件不是.NET程序集,所属类型库或自动化可执行文件。所以想确认是否可以在LabVIEW中加载.NET 2.0,3.0或3.5程序集?

解决方案

将配置文件放在LabVIEW.exe所属目录下,且命名为LabVIEW.exe.config。下面的样例程序会指引LabVIEW加载面向CLR 2.0的.NET混合模式程序集:

<?xml version ="1.0"encoding ="utf-8"?>
<configuration>
<startup useLegacyV2RuntimeActivationPolicy ="true">
<supportedRuntime version ="v4.0.30319"/>
</startup>
</configuration>

相关信息

LabVIEW使用一组默认配置来决定将引用哪个特定.NET程序集的版本以及将加载哪个通用语言运行库(CLR)的版本。例如,LabVIEW 2017默认使用.NET CLR 4.0,因为它可以使用.NET Framework 4.6.2,而LabVIEW 2012默认使用CLR 2.0,而CLR 2.0只能使用到.NET framework 3.5。您可以创建.NET配置文件以覆写LabVIEW加载CLR的默认文件,并执行该配置文件。

您也可以强行让LabVIEW加载面向CLR 2.0的.NET程序集。但是,配置面向旧版本CLR的程序集可能会出现难以预料的运行行为。

如果使用.NET 2.0框架创建可执行应用程序,请确保在该文件所在的文件夹中也存在可执行的配置文件。它须与LabVIEW.exe所属文件下的配置文件完全相同,但必须将其重命名格式为(Executable Name).exe.config。

注意:所支持运行版本的Token必须与安装的.NET Framework版本相匹配。您可以通过检查已安装的.NET 2.0版本的“添加/删除程序”来验证该项是否一致。

本文是否有帮助?

无帮助