VIs in a Package Cannot Find Dependencies

Updated Feb 16, 2018

Reported In

Software

  • JKI VI Package Manager

Issue Details

I installed a package through VI Package Manager and the package installed successfully. When I try to use the VIs in LabVIEW, I receive errors such as 'SubVI is not executable' or 'Xcontrol is broken'. How do I resolve these errors? 

Solution

This typically occurs when there are multiple versions or bitnesses of LabVIEW installed to one PC. You can check through VI Package Manager to see which version your package installed to. If the package was installed to a 64-bit version of LabVIEW, try uninstalling and reinstalling to a 32-bit version as most toolkits are only supported on 32-bit LabVIEW. 

You can also check to ensure that all dependencies have been installed by navigating within LabVIEW to Tools, and looking for your package there. If it is listed there, it may have a Check Dependencies option, which will then check to ensure any necessary dependencies have been installed. 

WAS THIS ARTICLE HELPFUL?

Not Helpful