원격 프론트 패널, NI 네트워크 브라우저 또는 WIF (Web Interface)가 내 브라우저에서 작동하지 않음

업데이트 됨 Aug 7, 2019

해당 제품

Software

  • LabVIEW Full

문의사항

Chrome에서 원격 프론트 패널에 액세스하려고하면 다음과 같은 메시지가 표시됩니다.

Mozilla Firefox에서 원격 프론트 패널에 액세스하려고하면 다음과 같은 동작이 나타납니다.

Chrome 또는 Mozilla Firefox에서 NI 네트워크 브라우저 또는 웹 인터페이스 (WIF)에 액세스하려고하면 다음과 같은 메시지가 나타납니다 :
이러한 기능이 제대로 작동하지 않는 이유는 무엇입니까?이 문제를 해결하려면 어떻게해야합니까?

해결책

이러한 웹 기술은 Netscape Plugin Application Programming Interface (NPAPI)라는 브라우저 플러그인 메커니즘에 의존합니다. 브라우저 보안을 강화하기 위해 NPAPI는 Google Chrome에서는 42 버전부터 ,Mozilla Firefox에서는 52 버전부터 더 이상 사용되지 않습니다.

Google 크롬 버전 사용자 정의 및 제어 버튼을 클릭하고 도움말 » Google 정보를 선택하여 Google 크롬 버전을 확인할 수 있습니다.


열기 메뉴 버튼을 클릭하고 도움말 메뉴 열기 버튼을 선택한 다음 Firefox 정보 메뉴 항목을 선택하여 Mozilla Firefox 버전을 확인할 수 있습니다

Google 크롬 버전 42 이상, Mozilla Firefox 52 이상 및 Microsoft Edge는 이전의 National Instruments 웹 기술에서 지원되지 않는 브라우저입니다. National Instruments는 고객이 지원되는 브라우저 (Internet Explorer)를 사용할 것을 적극 권장합니다.

LabVIEW NXG Web Module 및 SystemLink와 같은 최신 웹 기술은 Chrome, Firefox, Safari 및 Edge의 최신 버전을 지원합니다. 자세한 내용은 해당 제품에 대한 readme를 참조하십시오.

추가 정보

또한 NPAPI 플러그인은 Mozilla Firefox 버전 52가 출시된 후 Mozilla Firefox Extended Support 릴리스에서 계속 작동할 수 있습니다. 이전 버전의 Firefox에서 누락된 플러그인 문제가 발생하는 경우이 플러그인을 복원 ( Updating Mozilla Firefox Disables My Remote Front Panel Plugin ) 할 수 있습니다.

이 글이 도움이 되셨습니까?

도움 안됨