VISA Error In NI MAX Using Keysight IO Libraries Suite

Updated Dec 20, 2017

Reported In

Software

  • Measurement and Automation Explorer (MAX)

Driver

  • NI-VISA

Issue Details

I have both NI-VISA and Keysight IO Libraries Suite installed on my machine, and occasionally NI Measurement & Automation Explorer (NI MAX) shows a VISA Error with a yellow bang under Devices and Interfaces as shown in the image below. How can I resolve this error?

Solution

This error is caused by a compatibility issue between Keysight IO Libraries Suite 17.x and NI-VISA, and occurs when the NI-VISA Passport for Tulip is enabled in NI MAX. The issue is resolved in Keysight IO Libraries Suite version 17.2, Update 2 (17.2.20818.0). Complete the following steps if the error is encountered:
  1. Uninstall Keysight IO Libraries Suite versions 17.0 through 17.2, Update 1
  2. Install Keysight IO Libraries Suite version 17.2, Update 2 (17.2.20818.0) or later
Note that leaving the older software version installed and simply upgrading to the newer version could potentially cause problems with configuration.

WAS THIS ARTICLE HELPFUL?

Not Helpful