LabVIEW 파일을 이전 버전으로 변환하기

업데이트 됨 Jun 25, 2019

해당 제품

Software

  • LabVIEW

문의사항

  • 이전 버전의 LabVIEW에서 높은 버전의 VI를 사용할 수 있습니까?
  • 높은 버전의 VI를 이전 버전의 LabVIEW로 어떻게 다운 버전시킵니까?
  • 새로운 버전의 LabVIEW에서 낮은 버전의 VI를 열 수는 있지만, 이전 버전의 LabVIEW에서는 높은 버전의 VI가 열리지 않습니다. 파일 버전이 현재의 LabVIEW 버전보다 나중 버전이라는 오류가 발생할때, 이전 버전의 LabVIEW에서 어떻게 코드를 열 수 있습니까?

LabVIEW : File version is later than the current LabVIEW version.
'<VI name>'로드 중 오류가 발생했습니다.
LabVIEW로드 오류 코드 : 9 : VI 버전 (<VI version>)이 LabVIEW 버전 (<LabVIEW version>)보다 최신 버전입니다.

해결책

다른 버전의 LabVIEW에서 현재의 VI를 저장하려면 지금 보다 최신 버전의 LabVIEW를 사용해야합니다. 예를 들어, LabVIEW 2017에서 생성 된 VI를 열려면 , LabVIEW 2017 또는 이후 버전을 사용해야합니다.

  • LabVIEW 8.0 및 이후 버전

  • LabVIEW 도움말 문서를 따르십시오 : Save for a Previous Version

  • LabVIEW 7.0 및 이전 버전

  1. VI의 계층에서 최상위 VI에 대해, 파일(File)»옵션으로 저장방법 선택(Save with Options) 으로 저장 대화 상자를 여십시오.

  2. 이전 버전에 대한 VI 계층 구조를 저장하려면 이전버전에 저장하기(Save for Previous)를 선택하십시오.

  3. 저장(Save) 단추를 눌러, 디렉토리 선택(Choose a Directory) 대화 상자를 여십시오.

  4. VI 계층 구조를 저장할 디렉토리를 선택하십시오.

  5. 저장(Save) 버튼을 클릭하십시오.

  • 필요한 LabVIEW 버전이 없습니다

되돌리려는 VI를 열 수있는 LabVIEW 버전이 없다면, 포럼의 버전 변환 섹션은 VI를 되 돌리는 데 도움이되도록 커뮤니티에 연락하는 효과적인 방법입니다. 코드 변환 방법에 대한 지침은 아래 링크 된 페이지의 상단에 게시 된 변환 보드 규칙을 참조하십시오.

Conversion Board Rules

이 정보는 도움말»목차 및 색인 을 선택하여 사용할 수있는 LabVIEW 도움말에서도 이용할 수 있습니다 .

 

추가 정보

  • 최신 버전의 LabVIEW에서 새로 생긴 기능을 가진 VI는 이전 버전의 LabVIEW에서 해당 기능 을 사용 할 수 없습니다. 이 경우, 이전 버전에 VI를 저장하면 새 기능이 누락됩니다. 작동하지 않는 VI는 블록 다이어그램에 물음표가있는 VI로 대체됩니다.
  • Toolkit에는 자체 버전이 있기 때문에 한 번에 한 버전의 LabVIEW에만 툴킷을 설치할 수 있습니다.
  • vi.lib의 VI는 이전 버전에서도 저장되지 않습니다. VI가 이미 해당 버전에 존재하면 VI를 이전 버전으로 저장할 필요가 없습니다. 이전 버전의 LabVIEW에서 VI를 저장하면 vi.lib VI는 변환되지 않지만 해당 VI에 대한 참조는 그대로 유지됩니다. 이전 버전의 LabVIEW에서 VI가 열리면 새로 변환 된 VI가 해당 LabVIEW 버전의 vi.lib VI에 링크됩니다. 이 프로세스는 시간과 디스크 공간을 절약합니다. 새로 변환 된 VI는 이전 버전의 vi.lib VI를 사용하여 동일하게 기능합니다.
다른 버전의 LabVIEW로 생성 된 VI를 처리 할 수있는 각 LabVIEW 버전의 기능에 대한 자세한 내용은 아래 링크를 참조하십시오. (How to Upgrade or revert a VI to a Different Version of LabVIEW)

이 글이 도움이 되셨습니까?

도움 안됨