LabVIEWファイルを旧バージョンで保存する

更新しました Nov 17, 2018

使用製品

Software

  • LabVIEW

問題

  • VIを旧バージョンのLabVIEWで使用できますか?
  • VIを旧バージョンのLabVIEWに戻すにはどうすればよいですか?
  • 旧バージョンのLabVIEWでVIを開くにはどうすればよいですか?
  • 新しいバージョンのLabVIEWでVIを開くことはできますが、古いバージョンのLabVIEWではVIを開くことはできません。ファイルバージョンが現在のLabVIEWバージョンより新しいというエラーが表示されます。旧バージョンのLabVIEWでコードを開くためにできることはありますか?

LabVIEW:ファイルバージョンが現在のLabVIEWバージョンより新しいです。
'<VI name>'の読み込み中にエラーが発生しました。
LabVIEWロードエラーコード:9:VIバージョン(<VIバージョン>)がLabVIEWバージョン(<LabVIEWバージョン>)より新しいです。

解決策

LabVIEW旧バージョンのVI(およびその階層)を保存するには、そのVIが最初に保存されたバージョン以降のLabVIEWバージョンを使用する必要があります。たとえば、LabVIEW 2017で作成したVIを元に戻すには LabVIEW 2017以降を使用する必要があります。
 

LabVIEW 8.0以降

LabVIEWヘルプを参照してください: 旧バージョンで保存する


LabVIEW 7.0以前

  1. VI階層内にある最上位VIについては、ファイル>>オプションで保存を選択して、オプションを付けて保存ダイアログボックスを表示します。
  2. 旧バージョン用にVI階層を保存するには、旧バージョンへ保存を選択します。
  3. 保存ボタンをクリックして、ディレクトリの選択ダイアログボックスを表示します。
  4. VI階層を保存するディレクトリを選択します。
  5. 保存ボタンをクリックします。
旧バージョンへの保存に関する情報は、LabVIEWヘルプでも確認できます。ヘルプは、ヘルプ>>目次および索引を選択すると参照できます。
 

必要なLabVIEWバージョンがない

元に戻すVIを開くことができるLabVIEWバージョンがない場合は、フォーラムのVersion Conversionセクションは、VIを元に戻す際にコミュニティに助けを求める効果的な方法です。コードを変換する方法については、リンク先ページの上部にあるConversion Board Rulesを参照してください。

追加情報

  • LabVIEWの最新バージョンで導入された機能を持つVIは、新しい機能が存在しないLabVIEWの旧バージョンでは完全に機能することができません。この場合、新しいVIを旧バージョンに保存すると、古いバージョンのVIに新しい機能が表示されなくなります。機能しないVIは、ブロックダイアグラムに疑問符を含むVIに置き換えられます。
  • ツールキット内のVIを旧バージョンに保存することもできません。ツールキットには独自のバージョンがあるため、1つのマシン上にLabVIEWの1つのバージョンに対してしかツールキットをインストールすることができません。
  • vi.libのVIも以前のバージョンには保存されません。そのVIがすでにそのバージョンに存在する場合、VIを旧バージョンに保存する必要はありません。旧バージョンのLabVIEWでVIを保存すると、vi.lib VIは変換されませんが、そのVIへの参照はそのまま残ります。VIが旧バージョンのLabVIEWで開かれた場合、新しく変換されたVIはそのLabVIEWバージョンのvi.lib VIにリンクします。このプロセスにより、時間とディスク容量が節約されます。新しく変換されたVIは、旧バージョンのvi.lib VIを使用して同じように機能します。

異なるバージョンのLabVIEWで作成されたVIを処理するLabVIEWの各バージョンにおける対応性については、VIをNI LabVIEWの異なるバージョンにアップグレードまたは戻す方法を参照してください。

この記事はお役に立ちましたか?

いいえ