Missing Icons on Functions or Controls Palette

Updated Sep 18, 2018

Reported In

Software

  • LabVIEW

Driver

  • NI-DAQmx

Issue Details

  • The functions or controls palette is missing icons, subpalettes, toolsets, or drivers.
  • I get a warning saying Missing NI Module, Toolkit, or Driver
  • Cannot find .NET & ActiveX Palettes in my VI. 

Solution

The functions or controls palette may be missing icons or subpalettes for several different reasons. Please refer to the section below that describes your particular problem.  

Ensure that you are using a LabVIEW Development System that is compatible with your module or toolkit that is missing. Not all toolkits are available with the 64-bit version of LabVIEW. If you are using the 64-bit version of LabVIEW, you should first consult the Product Compatibility list to see if the toolkit you are missing is supported. If it is not supported, you may want to consider using the 32-bit version of LabVIEW instead.

 

I. Functions or Controls Palette is Blank

The Library Directory path setting in LabVIEW is not set to the default directory or the default directory has been incorrectly modified. This default directory is the location where the labview\vi.lib folder was installed and changing the Library Directory path back to this location on your hard drive should fix the problem. Use the following directions to navigate to this setting within your respective version of LabVIEW. 

LabVIEW 8.0 and Later: 

  1. Select Tools»Options and then select Paths from the "Category" menu.
  2. Then select Library Directory from the drop-down menu and confirm that the Use Default box is checked.

LabVIEW 6.x/7.x: 

  1. Select Tools»Options and then select Paths from the drop-down menu.
  2. Then select Library Directory from the drop-down menu and confirm that the Use Default box is checked.

LabVIEW 5.x and Earlier: 

  1. Select Edit»Preferences... and then select Paths and Library Directory from the drop-down menus.
  2. Confirm that the Use Default box is checked.
Another path to check is the Menus Directory. Instead of selecting Library Directory, select Menus Directory. Ensure that the path listed is correctly pointing to the menus folder: labview\menus.

 

II. The NI-DAQmx/NI-DAQ VIs Don't Appear in my LabVIEW Functions Palette

The Data Acquisition palette relies upon two installations: the LabVIEW installation and the DAQ driver installation. When the NI-DAQ drivers are installed, the installer will automatically detect the versions of LabVIEW present on the computer. Most often, the DAQ support for these versions of LabVIEW are then installed. This means that if you upgrade to a newer version of LabVIEW you will need to add DAQ support for your newer version of LabVIEW by modifying/reinstalling your DAQ drivers.

Steps to ensure driver VIs appear in LabVIEW:

  1. Ensure that all development environments being used (LabVIEW, CVI, etc.) have been installed before the device driver. Installing LabVIEW after a driver will not update the functions palette with those driver VIs. In this case, it is only necessary to modify the installation for those drivers that do not appear on the functions palette to include support for LabVIEW.
  2. Install the most current supported version of your device driver which is compatible with your version of LabVIEW, and be sure to include support for your specific LabVIEW version when prompted.
  3. Close and reopen LabVIEW. You should now see the appropriate icons for all installed drivers on the functions palette.
  4. There are several other reasons why certain functions may not appear on the palette. If the above steps do not resolve the problem, see Traditional DAQ Palette Does Not Appear In LabVIEW or contact National Instruments support.

Verify that the proper menu files have in fact been installed correctly: 

  1. If the respective DAQ and DAQmx VIs have been installed correctly, their menu files should be present: labview\vi.lib.
  2. The associated menu files should be installed in the following location: labview\menus\default. These menu files are ultimately what links the installed VIs to the functions palette in LabVIEW.
 

III. Newly Installed Toolset does not appear under the Functions Palette

Make sure that you have followed the download instructions and installed the toolset in the correct directory within LabVIEW. If you are currently running LabVIEW, exit and reopen LabVIEW. If the icon is still not visible,they may need to be manually added to the function palette as explained below in section IV.

 

IV. Icons or Palettes have Question Marks

If the icon has a question mark, or the palette is blank, then the file that the icon points to is in the wrong place, was deleted, or does not exist on your computer. To find out where the file is supposed to be located:
  1. Go to Tools»Advanced»Edit Palette Sets...
  2. Three windows will pop up: (a) the Edit Controls and Functions Palettes window, (b) the Controls window, and (c) the Functions window.
  3. In the Functions window, navigate to icon with the question mark.
  4. Right click and select Display Path to Menu File...
  5. The window that pops up will give you the path to the file that the icon looks to. 
The missing file may be a .mnu or .vi file depending on whether the icon represents a sub-palette or VI. You need to find this file, and put it in the path listed in the window. Make sure there are no intermediary files in the path that do not belong. If a whole palette is full of question marks, this indicates that the file containing these VI's does not have the correct path relative to the .mnu that it’s governing palette icon points to.

If the file listed in the window cannot be found on your computer, you may have deleted it, which will require you to either do a repair or reinstallation of the driver that supplied the .vi and .mnu files to LabVIEW, or if they come with LabVIEW, do a repair or reinstallation of LabVIEW.

 

V. Icons or Palettes are Missing

LabVIEW 7.0 and higher 

  1. Go to Tools»Advanced»Edit Palette Set
  2. Three windows will pop up: (a) the Edit Controls and Functions Palettes window, (b) the Controls window, and (c) the Functions window.
  3. Right click in empty space within the sub-palette and select Insert»Subpalette...
  4. Select the link to an existing menu file (.mnu) and click OK.
  5. Select Save Changes and exit and re-enter LabVIEW.

LabVIEW 6.1

  1. Pin the function palette to the block diagram or front panel by clicking on the pin in the upper left hand corner.
  2. Click on Options (the icon does not appear unless the function palette is tacked and looks like two bullets).
  3. Select Edit Palettes.
  4. Within the Function Palette, navigate to the location where you would expect the icon to appear.
  5. Right click in empty space within the sub-palette and select Insert»Submenu (as shown below).
  1. Select the link to an existing menu file (.mnu) and click OK.
  2. Select the dir.mnu.*
  3. Select Save Changes and exit and re-enter LabVIEW.
If the icon is still not visible, place your LabVIEW installation CD in the CD drive and try a Modify or Repair on your instance of LabVIEW.

*If there is not a dir.mnu that you can directly select, you may have installed into a different directory and need to look there or you may have deleted this file. Please contact NI's Customer Phone Support for further assistance.

 

VI. Missing an Entire Category of Functions

If you are missing an entire palette in LabVIEW, then verify that the palettes you are looking for are not already in LabVIEW, but just marked as hidden.
  1. Right-click the block diagram to open the functions palette.
  2. Select the double arrows at the bottom of the palette to expand it to full-size.
  3. Click Change Visible Palettes...
  4. Look through the list of palettes that appear for the one you are looking for. If you see it, make sure the check box next to it is checked. 
If you still cannot find the Palette you are looking for in the Available Palette Categories, make sure your VI is under the correct target in the project explorer window. Since different categories will appear depending on the target for example the .NET & ActiveX palette appear in the available palette categories only when the VI is under the PC target and not when the VI is under the Real Time or FPGA targets.

Additional Information

If you have LabVIEW 6.1 and upgrade to NI-DAQ 7.4.1 and LabVIEW 8.0, the DAQ palette from LabVIEW 6.1 will disappear. NI-DAQ 7.4.1 provides only LabVIEW 8.0, 7.1, and 7.0. support. In order to get Traditional NI-DAQ support for LabVIEW 6.1 while LabVIEW 8.0 is still installed, it is necessary to load the NI-DAQ 7.4 driver which will remove the Traditional DAQ support for LabVIEW 8.0. It is still possible to load NI-DAQmx 8.0 in order to have the latest DAQmx support in LabVIEW 8.0.
 

WAS THIS ARTICLE HELPFUL?

Not Helpful