This content is not available in your preferred language.

The content is shown in another available language. Your browser may include features that can help translate the text.

Missing Icons on LabVIEW Functions or Controls Palette

Updated Jul 10, 2020

Reported In

Software

  • LabVIEW
  • LabVIEW NXG

Issue Details

  • The functions or controls palette is missing icons, subpalettes, toolsets, or drivers.
  • I get a warning in LabVIEW saying Missing NI Module, Toolkit, or Driver.
  • I cannot find the .NET or ActiveX palettes.

Solution

This KnowledgeBase article refers to LabVIEW 8.0 or newer. For similar information and troubleshooting for LabVIEW 7.x or earlier, see Missing Icons on Functions or Controls Palette in LabVIEW 7.0 or Earlier.

The functions or controls palette may be missing icons or subpalettes for several different reasons. First ensure that you are entitled to the missing functions based on your LabVIEW or LabVIEW NXG edition.

Next ensure that you are using a LabVIEW Development System that is compatible with your module or toolkit that is missing. Not all toolkits are available with the 64-bit version of LabVIEW. If you are using the 64-bit version of LabVIEW, you should first consult the LabVIEW 32-Bit vs. 64-Bit Applications FAQ  for product compatibility information to see if the toolkit you are missing is supported. If it is not supported, you may want to consider using the 32-bit version of LabVIEW instead. 

If your software is compatible and you are missing icons or subpalettes that you know you are entitled to, please refer to the section below that describes your particular problem.  
 

I. Functions or Controls Palette is Blank

The Library Directory path setting in LabVIEW is not set to the default directory or the default directory has been incorrectly modified. This default directory is the location where the labview\vi.lib folder was installed and changing the Library Directory path back to this location on your hard drive should fix the problem. Use the following directions to navigate to this setting:
  1. Select Tools»Options and then select Paths from the "Category" menu.
  2. Then select Library Directory from the drop-down menu and confirm that the Use Default box is checked.
Another path to check is the Menus Directory. Instead of selecting Library Directory, select Menus Directory. Ensure that the path listed is correctly pointing to the menus folder: labview\menus.
 

II. Icons have Question Marks or Sub-Palettes are Blank

If the icon has a question mark, or the palette is blank, then the file that the icon points to is in the wrong place, was deleted, or does not exist on your computer. When prompted by the Installation Wizard for additional items to install, proceed with the default selection. Deselecting items may prevent LabVIEW configuration support for the add-on/toolkit from being installed, and will not resolve the problem.  
Follow the steps in section III if the issue still persists.



III. Icons or Palettes are Missing

  1. Go to Tools»Advanced»Edit Palette Set
  2. Three windows will pop up: (a) the Edit Controls and Functions Palettes window, (b) the Controls window, and (c) the Functions window.
  3. Right click in empty space within the sub-palette and select Insert»Subpalette... or Insert»VI(s)...
  4. Select the link to an existing menu or VI file (.mnu or .vi) and click OK.
  5. Select Save Changes and exit and re-enter LabVIEW.
 

IV. Missing an Entire Category of Functions

If you are missing an entire palette in LabVIEW, then verify that the palettes you are looking for are not already in LabVIEW, but just marked as hidden.
  1. Right-click the block diagram to open the Functions palette.
  2. Select the double arrows at the bottom of the palette to expand it to full-size.
  3. Click Change Visible Palettes...
  4. Look through the list of palettes that appear for the one you are looking for. If you see it, make sure the check box next to it is checked. 
If you still cannot find the Palette you are looking for in the Available Palette Categories, make sure your VI is under the correct target in the project explorer window. Since different categories will appear depending on the target for example the .NET & ActiveX palette appear in the available palette categories only when the VI is under the PC target and not when the VI is under the Real Time or FPGA targets.
 
 

V. Newly Installed Toolkit does not appear under the Functions Palette

  1. Make sure that you have followed all download instructions, including installing software in the correct order (LabVIEW and then any toolkits or modules) and installing the toolset in the correct directory within LabVIEW.
  2. If you are currently running LabVIEW, exit and reopen LabVIEW.
  3. If the icon is still not visible, they may need to be manually added to the function palette as explained in section IV.
Note: If you have subVIs in your VI that belong to a Module or Toolkit that you do not have installed, they will be grayed out.
 

VI. The NI-DAQmx VIs Don't Appear in my LabVIEW Functions Palette

Linked are troubleshooting resources available if your DAQ Assistant is missing in LabVIEW or you are experiencing limited DAQmx functionality after installing the DAQmx driver.
 

VII. Other Hardware Driver VIs Don't Appear in my LabVIEW Functions Palette

If the functions for a particular NI hardware driver (such as NI-FGEN, NI-SCOPE, NI-DMM, NI-Switch etc.) are missing in LabVIEW, even if you are able to test your  hardware in a MAX Test Panel.
First check the compatibility of your driver. You can find the supported LabVIEW versions inside readme of drivers.
If the version is supported you need to reinstall the driver.