Why Does My LabVIEW Executable Create an INI File After I Run It?

Updated Jan 12, 2018

Reported In

Software

  • LabVIEW 2017 Application Builder Module
  • LabVIEW Full

Issue Details

I just built an executable in LabVIEW. I noticed that after I run my executable, it creates an INI file. What is this INI file for, and/or why is it empty?

Solution

After you run your executable for the first time, you might find that "YourApp.ini" is just an empty file created by "YourApp.exe." Unless you change options in your executable (under Tools»Options), this file will likely remain empty.

Additional Information

​INI files are platform-independent configuration files that can be used to modify certain parameters of your executable (e.g., colors, fonts, TCP/IP access, etc.). They are very similar to a normal text file (as evidenced by the fact that you should be able to open your INI file in a text editor) but are a little more robust. If you are deploying executables to machines that may have a different platform than the machine on which you developed your application, a normal text file (that you might create with the "write file" function in LabVIEW) may not behave as you expect on the target machine.

To test the functionality of the INI file, you can navigate to Tools»Options»Colors and change the colors of your front panel, these new settings will be saved in "YourApp.ini." After generating your executable and running it for the first time, the INI file might look something like this:

[YourApp] 
prefDlgTestData=1234 
menu.foreground=00FF2A59 
postScriptLevel2=False 
colorHistoryItemA=001247FF 
colorHistoryItemB=00FF2A59 


The next time you open "YourApp.exe", it will read "YourApp.ini" and change the default colors accordingly. As long as the INI file is in the same file directory as the executable, the executable will utilize the settings from the INI file.

WAS THIS ARTICLE HELPFUL?

Not Helpful